Author Topic: AdultDVDEmpire script  (Read 18452 times)

0 Members and 1 Guest are viewing this topic.

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #40 on: February 19, 2015, 05:24:53 am »
pra15 fixed the script to handle a change in ADE's page format. They added a "video preview" option to all newer DVDs, which broke the extraction of poster/cover images. (ref: http://www.videodb.info/forum_en/index.php/topic,3966.0.html)

Attached is a complete copy of the script with the changes. This is based on GazonkFoo's version of the script. (I added the ability to disable the downloading of back-cover images, it's controlled by a flag in the "const" section at the top.)

Note: the "AdultDVDEmpire" script posted on the PVD Downloads page (labelled as 0.1.1.1) DOES NOT WORK with the current ADE website layout. In fact, it will lock up Personal Video Database if run! The script version written by GazonkFoo (with mod by pra15) does work.

Offline scarlite

  • Member
  • *
  • Posts: 1
    • View Profile
Re: AdultDVDEmpire script
« Reply #41 on: April 07, 2015, 11:50:41 pm »
Thankyou so much! Been tearing my hair out trying to get the old one working. Thought it was something I'd done.

Offline pra15

  • Power User
  • ****
  • Posts: 164
    • View Profile
Re: AdultDVDEmpire script
« Reply #42 on: June 27, 2015, 11:19:21 am »
AdultDvdEmpire change code in the results page. PVD put the page result as URL of the movie.

Modification of the procedure parsesearchresult :

Code: [Select]
procedure ParseSearchResults(HTML: string);
var
  ItemStart, ItemEnd: Integer;
  Title, Studio, Year, URL, Preview: string;
begin
  ItemStart := Pos('Category "List Page" Label="Boxcover">', HTML);
  while ItemStart > 0 do
  begin
    ItemEnd := PosFrom('Category "List Page" Label="Boxcover">', HTML, ItemStart+1);

    URL := BASE_URL + HTMLValue(HTML, ItemStart, ItemEnd, '<h3><a href="', '"');
    Preview := HTMLValue(HTML, ItemStart, ItemEnd, 'Label="Boxcover"><img src="', '"');
    Title := HTMLValue(HTML, ItemStart, ItemEnd, 'Label="Title">', '</a>');
    Studio := HTMLValue(HTML, ItemStart, ItemEnd, 'studio</small>', '</a>');
    Year := HTMLValue(HTML, ItemStart, ItemEnd, '<small>(', ')</small>');

    LogMessage('title: '+ Title +', studio: '+ Studio +', year: '+ Year +', url: '+ URL +', preview: '+ Preview);
    AddSearchResult(Title, Studio, Year, URL, Preview);

    ItemStart := ItemEnd;
  end;
end;

In the results page on AdultDVDEmpire, the movie must have a thumbnail to work.
I tried it and it seems to work.

I don't know the version of my script but like said Aimhere in the precedent message i suppose it is based of Gazonfoo's script.

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #43 on: July 05, 2015, 08:30:19 pm »
Thanks, pra15!

Here is the complete script, version bumped to 0.1.2.4 now.

I had to make a minor edit, ADE changed the HTML near the "Matches Found" text (the script wouldn't interptret it properly otherwise). But it seems to work now.

Aimhere

Offline pra15

  • Power User
  • ****
  • Posts: 164
    • View Profile
Re: AdultDVDEmpire script
« Reply #44 on: July 08, 2015, 12:32:00 am »
Thanks AimHere,

I saw sometimes the URL is not find, i have modified search results and change the method to find URL.

I have made some tests, it seems to be OK now.

Offline pra15

  • Power User
  • ****
  • Posts: 164
    • View Profile
Re: AdultDVDEmpire script
« Reply #45 on: July 17, 2015, 10:20:44 pm »
AdultDvdEmpire change script of movie page.

A little modification to find poster url.

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #46 on: July 26, 2015, 07:12:37 pm »
Thanks again, pra!

Offline woland68

  • User
  • ***
  • Posts: 31
    • View Profile
Re: AdultDVDEmpire script
« Reply #47 on: August 02, 2015, 04:43:11 pm »
I found a bug in the script (latest version, 0.1.2.5)  :-\
when the discharge cover, the first cover (front) is replaced with the rear (back)
not all the titles this happens, and strange  ???
I posted a video to understand

https://mega.co.nz/#!ldZAgQpC!d20HOAveRusQ1mnjowcI9PaA3rbP5kAPnbm9TTp9shg

Thanks
« Last Edit: August 02, 2015, 04:44:59 pm by woland68 »

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #48 on: August 02, 2015, 06:32:42 pm »
Huh. I haven't had much of a chance to play around with the new script yet. Maybe pra15 has an idea...

(By the way, ADE *really* needs to stop mucking with their site design. The new page layouts are God-awful! :P)

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #49 on: August 09, 2015, 06:07:43 pm »
A couple of (minor) fixes...

I noticed the script wasn't importing Tagline, Description, or Customer Rating ("Additional Rating") anymore. Fixed this, new version 0.1.2.6 attached.

Note that ADE now uses the movie title as a tagline by default when a movie doesn't have a specific tagline. So the "Tagline" field will receive text for every movie now, regardless of whether it's really a tagline or not. This can't be worked around, unfortunately. (If I were really clever, I'd compare the extracted "tagline" to the movie title, and set the tagline to null if they matched. If I were clever. :) )

Also, note that ADE changed the way the movie categories (genres) are listed, breaking the script. So the script isn't importing that info right now. This is going to take some work to fix (the categories/genres are going to have to be parsed the same way actors are parsed), and I'm not quite able to wrap my head around the problem right now...

Aimhere
« Last Edit: August 09, 2015, 06:09:19 pm by AimHere »

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #50 on: August 09, 2015, 09:20:37 pm »
More fixes... script wasn't finding Genre or Studio or Duration or Release Date, the list of actors was getting extra (bad) entries, the director's name was getting extra text appended to it, the Release Date was formatted incorrectly (and not stored). And, if a producer was present, the script would go into an infinite loop (yikes!) because it wasn't being parsed correctly.

Hopefully this covers most of the recent site changes.

Aimhere

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #51 on: February 22, 2017, 08:21:58 pm »
Sorry I haven't been updating the script, haven't been able to work with PVD much lately.

More changes on ADE website. Script wasn't finding the production year, tagline or description... fixed.

Also, I discovered that not only was the film duration not being calculated correctly (its value should be in seconds, not minutes), but it wasn't even being saved to the correct XML field (and thus not actually being saved at all).

aimhere

(As always, save as "adultdvdempire.psf" in the scripts folder.)
« Last Edit: February 22, 2017, 09:00:37 pm by AimHere »

Offline AimHere

  • Power User
  • ****
  • Posts: 199
    • View Profile
Re: AdultDVDEmpire script
« Reply #52 on: February 26, 2017, 06:24:41 pm »
One more bug I discovered, when you run the script it does a search on ADE based on your specified movie title, and displays a list of the matches found in a window so you can select the best match. But the last item in said list is always blank... and if the search only returned one hit to begin with, then all you get is a blank box.

I'll try to work on this when I can, but considering ADE's search engine always returns dozens of hits for almost every search, it's not a real high priority for me.

aimhere