Author Topic: PVD v0.9.9.21, IMDB [EN] plugin v0.9.8.5 not downloading or updating IMDB Rating  (Read 25801 times)

0 Members and 1 Guest are viewing this topic.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2520
    • View Profile
imdb script is not working again. When I tried to fetch a movie, nothing is fetched beside the imdb link.

sorry...false alarm..it works after i restarted my pc

All right, you alerted me to the error.

Probably use the stable version 0.9.9.21 the which unfortunately I have not tested earlier versions of the script. I tested the beta version 1.0.23 is where these problems do not appear.  The problem is the url address in the search results.
Now it is corrected and hopefully it will not be more problems.

I fixed search results with the url.

Imdb Movie script
v 0.1.0.4
Imdb Movie(1) script
v 0.1.0.3

Scripts is attached here.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline abubin

  • User
  • ***
  • Posts: 54
    • View Profile
i am sorry..i am using 1.0.2.3 and I think I screw up my imdb plugins. Please read about this in another thread I posted. Cause my problem doesn't fit this thread...

http://www.videodb.info/forum_en/index.php/topic,3281.0.html


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2520
    • View Profile
imdb script is not working again. When I tried to fetch a movie, nothing is fetched beside the imdb link.

sorry...false alarm..it works after i restarted my pc

All right, you alerted me to the error.

Probably use the stable version 0.9.9.21 the which unfortunately I have not tested earlier versions of the script. I tested the beta version 1.0.23 is where these problems do not appear.  The problem is the url address in the search results.
Now it is corrected and hopefully it will not be more problems.

I fixed search results with the url.

Imdb Movie script
v 0.1.0.4
Imdb Movie(1) script
v 0.1.0.3

Scripts is attached here.

The Appendix to the post:
« Reply #40 on: 27 January 2013, 10:07:48 »


This is corrected code for Search results:
Code: [Select]
procedure ParseSearchResults(HTML : String);
var
curPos, endPos : Integer;
Title, Title1, Year, URL, Preview, Preview1 : String;
begin
curPos := Pos('<table class="findList">', HTML);
if curPos < 1 then
Exit;

LogMessage('Parsing search results...');

curPos  := PosFrom('<img src="', HTML, curPos)+10;
endPos  := PosFrom('.jpg" height="44" width="32" /></a>', HTML, curPos);
Preview := Trim(Copy(HTML, curPos, endPos - curPos));
curPos := PosFrom('<a href="/title/', HTML, curPos);
while curPos > 0 do begin
endPos := PosFrom('?ref_=fn_tt_tt_', HTML, curPos);
URL := Trim(Copy(HTML, curPos+9, endPos - curPos-9));
URL := BASE_URL + URL;
curPos := PosFrom('>', HTML, curPos)+1;
endPos := PosFrom('</td> </tr>', HTML, curPos);
Title := RemoveTags(Trim(Copy(HTML, curPos, endPos - curPos)), false);
Title   := StringReplace(Title, '-', #13, true, false, true); 
curPos  := PosFrom('<img src="', HTML, curPos)+10;
endPos  := PosFrom('.jpg" height="44" width="32" /></a>', HTML, curPos);
Preview := Trim(Copy(HTML, curPos, endPos - curPos));
AddSearchResult(Title, '', '', URL, '');
curPos := PosFrom('<a href="/title/', HTML, curPos);
 end;
end;

function NextMode(curMode : Integer) : Integer;
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline davfarm

  • Member
  • *
  • Posts: 2
    • View Profile
I have PVD v0.9.9.21 with the latest IMDB plug-in.  Yesterday 130129 the movie info stopped working.  The program reaches IMDB and reads some data but doesn't update the movie info.  I downloaded all updates, checked that I had the latest IMDB plug-in, and even did a clean install of the program trying to get it to work. I rebooted the machine to no avail.  I even tried my laptop which hasn't had a java update or the latest IMDB plug-in.  The program was working perfectly on Monday and failed on Tuesday and is still unable to get the IMDB info.  I feel that IMDB has changed something which is not allowing access.  I am using Windows 7 and I checked to make sure PVD is allowed through the firewall.  I am at a loss.  Please help.

Offline bmsmcr

  • Member
  • *
  • Posts: 5
    • View Profile
I have PVD v0.9.9.21 with the latest IMDB plug-in.  Yesterday 130129 the movie info stopped working.  The program reaches IMDB and reads some data but doesn't update the movie info.  I downloaded all updates, checked that I had the latest IMDB plug-in, and even did a clean install of the program trying to get it to work. I rebooted the machine to no avail.  I even tried my laptop which hasn't had a java update or the latest IMDB plug-in.  The program was working perfectly on Monday and failed on Tuesday and is still unable to get the IMDB info.  I feel that IMDB has changed something which is not allowing access.  I am using Windows 7 and I checked to make sure PVD is allowed through the firewall.  I am at a loss.  Please help.

I am having the same problem as stated above and have taken the same steps in hopes to fix it. Any assistance would be greatly appreciated!

Offline Rickylef

  • Member
  • *
  • Posts: 11
    • View Profile
Hi everybody!

I've got some problems and first of all is that I'm french, so I can speak a little bit of english and I hope i can explain clearly  and understand your eventual answers... So i'm not a master es computer and somme specific terms can be hard for me to understand.

But my principal problem is that I can't import data from imdb. I click on the button on the top, and, usually, informations take place but since I've got the new version, nothing works. I think it's because of a wrong tense in my URL windows on the search web page. Some informations are writen in red, but i can't write correctly the right tense.

Can somebody help me, please?

Sorry for my horrible english...

Friendly

Ricky

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Quote
But my principal problem is that I can't import data from imdb. I click on the button on the top, and, usually, informations take place but since I've got the new version, nothing works.

Check that your IMDb plugin is up-to-date. Select (for program version 1.0.2.x, from the menu button on the title bar) Help > Check for updates. The latest plugin version is 0.9.8.12.

 

anything