Author Topic: Odd bug when switching views  (Read 1007 times)

0 Members and 1 Guest are viewing this topic.

Offline AimHere

  • Power User
  • ****
  • Posts: 202
    • View Profile
Odd bug when switching views
« on: May 24, 2015, 02:52:14 pm »
Keep running into a minor bug in PVD 1.0 when changing between Movie and People views. Specifically, when using the Search functions.

If I am in Movies view, and enter something in the Search panel, I get a list of matching movies. If I then click on one movie, [optionally edit it], click on another, then switch to People view and back again, often the previously-selected movie is displayed again, NOT the more recently-selected one.

Something similar happens if I start off in People view, do a search, select a person, select another, then switch to Movies view and back again. PVD displays the record for the previously-selected person instead of the most-recently-selected one.

This doesn't happen ALL the time, but pretty frequently. It only happens the first time I switch views after doing a search. It doesn't happen anymore after switching views again... until the next time I do a search.

Admittedly, it's a VERY minor issue, but I figured I may as well report it anyway.

Steps to reproduce:

1) Start off in Movies view. Make sure the Search panel is visible.
2) Enter a search query where you know it will return multiple results.
3) Select one of the results in the list on the left.
4) Now select a different record.
5) Switch to People view.
6) Switch back to Movies view.

More often than not, PVD will display the record for the movie selected in step 3, rather than the one selected in step 4.

The same thing happens if you reverse Movie and People views in the steps above.