Personal Video Database

English => Support => Topic started by: Ivek23 on December 15, 2014, 11:37:09 am

Title: PVD problem with https://
Post by: Ivek23 on December 15, 2014, 11:37:09 am
How to the solve this problem with https:// :

It seems like PVdB script GET funtion does not recogniced the "https://" prefix

Script:
TheMovieDB [ES] 2014 (Easy Script)  (http://www.videodb.info/forum_en/index.php/topic,3881.msg18614.html#msg18614)

The problem is with the transfer of information from TheMovieDB web pages. (https://www.themoviedb.org/)

Log Message
Code: [Select]
(14.12.2014 15:03:54) PVD Version: 0.9.9.21
(14.12.2014 15:03:54) OS: Windows 7 Home Basic Edition
(14.12.2014 15:03:54) Plugin loaded: imdb.dll 0.9.8.25
(14.12.2014 15:03:54) Plugin loaded: imdb2.dll 0.9.8.24
(14.12.2014 15:03:54) Plugin loaded: plainexp.dll 0.7.1.1
(14.12.2014 15:03:54) Plugin loaded: scriptint.dll 0.2.6.1
(14.12.2014 15:03:55) Plugin loaded: valueconvert.dll 0.1.0.2
(14.12.2014 15:03:55) Compiling script: TheMovieDB_[ES]_2014.psf
(14.12.2014 15:03:55) Script compiled successfully: TheMovieDB_[ES]_2014.psf
[Warning] (514:19): "True and" is not needed
[Warning] (526:21): Calculation always evaluates to False
(14.12.2014 15:03:55) Executing script binary
(14.12.2014 15:03:55) Script loaded: TheMovieDB_[ES]_2014.psf 0.1.7.2
(14.12.2014 15:03:55) Loading database: D:\MyPVD\Personal Video Database 11M\Nova mapa\MOVIES.PVD
(14.12.2014 15:03:56) UpdateToolbar: 1
(14.12.2014 15:03:57) UpdateToolbar: 2
(14.12.2014 15:03:57) UpdateToolbar: 3
(14.12.2014 15:04:02) Compiling script: TheMovieDB_[ES]_2014.psf
(14.12.2014 15:04:02) Script compiled successfully: TheMovieDB_[ES]_2014.psf
[Warning] (514:19): "True and" is not needed
[Warning] (526:21): Calculation always evaluates to False
(14.12.2014 15:04:02) Executing script binary
(14.12.2014 15:04:02) Logging in...
(14.12.2014 15:04:02) Searching movie information for: Blade
(14.12.2014 15:04:02) GET: http://www.themoviedb.org/search/movie?query=Blade
(14.12.2014 15:04:02) Redirected to: https://www.themoviedb.org/search/movie?query=Blade
(14.12.2014 15:04:02) IOHandler value is not valid
(14.12.2014 15:04:10) UpdateToolbar: 4
(14.12.2014 15:04:10) UpdateToolbar: 5

As shown in the present example TheMovieDB when the page is
start url address "http://" into "https://" and now the script for this page yet find search results just by using the api-key, the transfer of information from TheMovieDB web pages it does not work anymore.

I think that in the future more and more web pages start url title changed to "https://" and the script and maybe even plugins will no longer work,
because it does not use the api-key options, as is the case TheMovieDB web page.

I guess the solution needed this one:

PVdB new version? ;D Please ....

More info:
http://www.videodb.info/forum_en/index.php/topic,1977.msg18633.html#msg18633

http://www.videodb.info/forum_en/index.php/topic,3881.msg18614.html#msg18614
Title: Re: PVD problem with https://
Post by: Ivek23 on July 02, 2016, 07:36:05 am
Important news:

Script don't work anymore.

It is true, Amazon.com is the next Web site that is passed to a secure https:// connection.
Title: Re: PVD problem with https://
Post by: Ivek23 on July 02, 2016, 07:36:35 am
Quote
Important news:

Script don't work anymore.

It is true, Rottentomatoes.com is the next Web site that is passed to a secure https:// connection.
Title: Re: PVD problem with https://
Post by: Ivek23 on July 31, 2016, 06:19:48 am
The following information is from the Russian part of forum:

Quote
Perhaps if all active users write Nostra, with a request to do a little upgrading. He will say and do a small upgrade.
Title: Re: PVD problem with https://
Post by: Ivek23 on July 31, 2016, 08:29:26 am
Important news:

Kinopoisk.Ru scripts don't work anymore and KinoPoisk.Ru is the next Web site that is passed to a secure https:// connection.
Title: Re: PVD problem with https://
Post by: Ivek23 on August 21, 2016, 12:04:13 pm
Maybe someone knows a program similar to the Proxomitron (http://www.proxomitron.info/files/) and how it works, we can send via my e-mail (http://www.videodb.info/forum_en/index.php/topic,4050.msg19580.html#msg19580) or publish it here.
Title: Re: PVD problem with https://
Post by: Ivek23 on November 28, 2016, 07:29:50 pm
Quote
Important news:

Script don't work anymore.

It is true, Rottentomatoes.com is the next Web site that is passed to a secure https:// connection.

Instead of the Rottentomatoes script is now new Rottentomatoes_ [HTTPS] script, where it now operates using curl program.

Rottentomatoes_ [HTTPS] script, can be found at this link:

http://www.videodb.info/forum_en/index.php/topic,4079.0.html

curl program and all of it can be found at this link:

http://www.videodb.info/forum_en/index.php/topic,4070.0.html
Title: Re: PVD problem with https://
Post by: Ivek23 on December 17, 2016, 11:28:27 am
Important news:

Script don't work anymore.

It is true, Amazon.com is the next Web site that is passed to a secure https:// connection.

All Amazon plugins works again.

For more information, read this topic Proxomitron - next https solution for PVD (http://www.videodb.info/forum_en/index.php?topic=4083.0) in the Development section.
Title: Re: PVD problem with https://
Post by: Ivek23 on October 26, 2017, 07:07:23 am
Important news:

AllMovie.com_new script don't work anymore and AllMovie.com is the next Web site that is passed to a secure https:// connection.

AllMovie.com works with AllMovie.com_new_HTTPS script version 1.1.2.6 (http://www.videodb.info/forum_en/index.php?action=dlattach;topic=4109.0;attach=6543) or  AllMovie.com_new_HTTPS script version 1.1.2.5 (http://www.videodb.info/forum_en/index.php?action=dlattach;topic=4109.0;attach=6541) again.

For more information, read this topic Proxomitron - next https solution for PVD (http://www.videodb.info/forum_en/index.php?topic=4083.0) in the Development section and Allmovie.com https (http://www.videodb.info/forum_en/index.php/topic,4109.msg20181.html#msg20181) topic in the
Support section