Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - oenghus

Pages: [1]
Scripts and Templates / IAFD People
« on: November 14, 2013, 04:25:33 am »
There is a problem loading the image for some people and I think it's where the image URL contains spaces. The URL for the person is:

The current procedure in the script I use is:

procedure ParsePhoto(PhotoURL : String);
   LogMessage('PARSING PHOTO...' + PhotoURL);
   PhotoURL:=HTMLToText (PhotoURL);

PVD log:

PARSING PHOTO... adams aalluredotcom hs.jpg
Url di download: Foto
GET: adams aalluredotcom hs.jpg
HTTP/1.1 400 Bad Request

I tried replacing spaces in PhotoURL with %20 before AddImageURL but it didn't make any difference.

Does anyone have any ideas how to fix this ?


Support / Multiple people with same name
« on: August 29, 2012, 02:00:34 am »
I have a problem where I have a number of people who appear twice. The duplicates have the same name and each have movies associated. I don't want to remove the duplicates as they will no longer be associated with the movies.

Is it possible to select the duplicate people and merge them into a single entry or is there another way to merge them ?



Scripts and Templates / Re: AdultDVDEmpire script
« on: August 18, 2012, 02:06:48 am »
Just tried the movie in PVD and
The posters (front & back) work in 0.9 and as you said won't load in 1.0 :(

I don't have a clue why this is broken in the new version, so maybe one of the devs could help me out.

I've reverted back to until the issue with AddImageURL is fixed.  :(

I may move the text that you add for the Tagline into the Description as I use the Tagline for something else.

Thanks for all your work. 8)

Changelogs / Re: Beta
« on: August 17, 2012, 12:04:41 pm »
Looks like a problem with AddImageURL in scripts woth,3197.20.html


Scripts and Templates / Re: AdultDVDEmpire script
« on: August 15, 2012, 02:17:11 am »
I've tried another script that uses AddImageURL and that doesn't save the poster either but I know that it used to work before I upgraded from

Thanks for investigating.

Scripts and Templates / Re: AdultDVDEmpire script
« on: August 15, 2012, 12:10:05 am »
I'm using PVD

I can't get posters for any film from Adult DVD Empire but try:

I created a new database and then added the title. When I import using your latest script I get everything except the posters.

If I go back to version of the script and recompile, I get the poster.


Scripts and Templates / Re: AdultDVDEmpire script
« on: August 14, 2012, 04:12:15 am »
i converted my script to pascal style (according to and the other scripts) so others can pick this up.

furthermore i extended the script so everything available on ADE should now be parsed.
the following fields are handled: title, studio, year, poster (front and back), tagline, description, actors, directors, producers, genre, features, mpaa, rating, release date, duration

Thanks for taking this on.  :)

I discovered a couple of issues as I don't get any posters and the description isn't complete and has <p> tag at the beginning.

Changelogs / Re: Beta
« on: July 04, 2012, 01:14:45 am »
I'm running PVD on Windows XP SP3

Regional options are set to English (United Kingdom)

Short date format is dd/MM/yyyy

Long date format is dd MMMM yyyy


Changelogs / Re: Beta
« on: July 03, 2012, 02:38:32 am »
Thanks for the best movie database available.  ;D

I have been using version for some time and I have recently upgraded as I have a problem when grouping by Date Added.

I initially see the tree view showing the count of titles grouped by dates. If I try to expand the group, either the + just disappears or I get the error:

conversion error from string "30/03/2012"
Overflow occurred during data type conversion.
Error Code: 14

I found a few reports for this for version but not for this version.

If I set the Group By back to none, should I be able to key in a specific date to search by Date Added as I cannot get any date format to work ?

Thanks again.

Scripts and Templates / Re: search not working
« on: June 26, 2012, 01:44:35 am »
You're right joc, other plugins do run twice when checked but not if unchecked or indeterminate. Try "Ghostbusters" and import from IMDB (IMDB uses data from loads of different pages) to see the extras parsing after the fields in PVD have been updated.

It does seem to be a peculiarity of adultdvdempire that it creates the extra movie entries. Is something happening with apostophes in the title so that when the selection is checked and the script runs the 2nd time , is it assuming it has a different movie because of the apostrophe and creating a new movie entry ?

Scripts and Templates / Re: search not working
« on: June 26, 2012, 01:13:53 am »
I probably wouldn't have noticed but I was testing with a movie that had an apostrophe in the title and I saw the duplicate.

I'll also try with other plugins.


Scripts and Templates / Re: search not working
« on: June 24, 2012, 12:54:58 am »
Thanks joc  ;D

I've tried a few movies but it sometimes creates duplicates.

I had a go at identifying what happens and it seems to be with titles where the search returns multiple results. When you see the results from the search in the Select Movie dialog, each title has a check box. If you click the check box twice (to see the tick) and watch the status bar, you can see that the script is running twice as it updates the movie and then loads the image again. If the movie title contains an apostrophe, it created a duplicate with the studio as the title field.

I've also had the Select Movie dialog again after updating the movie where it displays a list of movies with no search criteria which may be related, but I cannot reproduce this.

That's as far as I have managed to track but I hope it makes sense. I've not looked at scripting much as yet but I'll see what other debug may be available.

Thanks again for your help with getting the script going again.


Scripts and Templates / AdultDVDEmpire script
« on: June 05, 2012, 05:27:10 pm »
It looks like they have changed the whole search method as it returns the URL and no results.

Pages: [1]