Author Topic: two BUGS with SQL queries  (Read 2037 times)

0 Members and 1 Guest are viewing this topic.

Offline Anson

  • User
  • ***
  • Posts: 46
    • View Profile
two BUGS with SQL queries
« on: September 21, 2009, 10:04:11 am »
first bug, in advanced search:
I had defined several custom items, among them some "Select List" and some "Multiselect List".
When i try to do an advanced search "(loc1 IS NOT NULL) and (loc2 IS NOT NULL)", i get the following errorbox:
Code: [Select]
Dynamic SQL Error
SQL error code = -204
alias MOVIES CUSTOMSHORT154601265 conflicts with an alias in the same statement
Undefined name
Error Code: 249

To eliminate possible side effects from my database, upgrading the version, etc, I did the same test again with a fresh (newly created) database in v14, first adding only one field of both types, and then doing an advanced search on the empty database with the same advanced query "(loc1 IS NOT NULL) and (loc2 IS NOT NULL)". The result was the same errorbox as above (except for a different name "CUSTOMSHORT155341073")

more tests:
- changing the condition (IS NULL, = "x", contains "y") resulted in the same error.
- doing the tests with two "Select List" results in no error.
- doing the tests with two "Multiselect List" results in no error.
- changing the order "(loc2 ...) and (loc1 ...)" gives the same error again.

second bug, in displaying a grouped listing:
after i started PVD again and opened my normal database, the old grouping (context menu "group as") was lost and instead the standard grouping was used (is that a feature or a minor bug too; it would be nice if such settings would be saved and restored for each database and between PVD sessions).

The standard grouping is according to the original title's first letter, and everything seemed to be nicely grouped, including movies which start with digits and also some special chars. I could expand (click on the little "+" sign to the left of the group) groups which start with a dot ( in case someone needs such a title for testing himself), a minus, an asterisk (, but when I want to expand the group which has single apostrophes ("'", like in, I get an SQL error:
Code: [Select]
Dynamic SQL Error
SQL error code = -104
Unexpected end of command - line 1, column 376
Invalid token
Error Code: 249

when I did the same again now (a few hours later), i get no such errormessage, but the rest stays the same: the "+" in front of the folder symbol disappears, the folder symbol stays the same (with a green plus sign on it) and no details/movies from the group are listed.