Author Topic: Search problem due to prefix  (Read 2614 times)

0 Members and 1 Guest are viewing this topic.

Offline arj0n

  • User
  • ***
  • Posts: 32
    • View Profile
Search problem due to prefix
« on: October 03, 2009, 08:06:07 pm »
I'm using v0.9.9.14.

First I let the program search a movie at IMBd.
Then I use Import -> [NL] Get movie info from Moviemeter.nl in order to get the dutch description of the movie placed in the field Comments.
The problem is that when a movie has for example a prefix like ", The" in the field "Original Title" (My preference setting is "Put prefix at the end of the title"), the program can't find the movie title at moviemeter.nl. As result you just get a alphabetical list of movies which never includes the one I'm looking for.

To solve this I have to remove the prefix from the "original title" field in order to let the program find the movie at moviemeter.nl. After that I have to put the prefix back in the "original title".
(Or copy past the URL from moviemeter into the field URL and then use Import -> [NL] Get movie info from Moviemeter.nl because it looks like this program search by URL first if there is any in the field URL. But this option is way more work then removing the prefix temporary...)

Is this a sort of bug or am I doing something wrong?

B.T.W.: awesome program, the best of all the movie-collecting-apps around!!!
« Last Edit: October 03, 2009, 08:20:48 pm by arj0n »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Search problem due to prefix
« Reply #1 on: October 03, 2009, 11:29:53 pm »
My very limited testing suggests it's a bug in the MovieMeter plugin. A search of a title with it's prefix appended at the end (my test case was Vierde Man, De) returns a long list of meaningless hits, while the same search done at the website works fine (in fact, the website even lists the titles in this format).

The problem could by avoided by using the "remove (prefix) from title" title formatting preference.

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: Search problem due to prefix
« Reply #2 on: October 12, 2009, 11:15:21 pm »
The site (moviemeter.nl) itself fails to search for movies with prefixes. I will try to solve the problem by removing prefixes in the plugin when I find some free time.
Gentlemen, you can’t fight in here! This is the War Room!

 

anything