Author Topic: [SOLVED] IMDb plugin shows strange behaviour  (Read 16954 times)

0 Members and 1 Guest are viewing this topic.

Offline Overlord

  • Member
  • *
  • Posts: 12
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #20 on: November 22, 2009, 07:24:08 pm »
Everything right except it doesn't download the small image from IMDb anymore (happening since the latest 2 or 3 plugins if I remember right).
Love not having to download the big and, for me, useless poster.

p.s. Could you also please make PVD remember the setting of the checkboxes in "scan result" window?

Keep up the great work!

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: IMDB plugin shows strange behaviour
« Reply #21 on: November 22, 2009, 07:32:28 pm »
Quote
Everything right except it doesn't download the small image from IMDb anymore (happening since the latest 2 or 3 plugins if I remember right).

Note that you need to check the option "Download images" in plugin configuration in order to get posters from IMDB.

Quote
p.s. Could you also please make PVD remember the setting of the checkboxes in "scan result" window?

It uses folders set up in Tools -> Preferences -> File Scanner
Gentlemen, you can’t fight in here! This is the War Room!

Offline Overlord

  • Member
  • *
  • Posts: 12
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #22 on: November 22, 2009, 09:08:48 pm »
Quote from: nostra
Note that you need to check the option "Download images" in plugin configuration in order to get posters from IMDB.

Ah a new option, thank you for the information, it works right ;)

Quote from: nostra
It uses folders set up in Tools -> Preferences -> File Scanner

Maybe I've explained it too briefly. I meant after folder checking, where the program asks what you want to do of the new movies found. I usually only import movie informations and deselect the second checkbox (poster). The options remains only during current session. Know is an idiot request, but tried anyway  ;D

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: IMDB plugin shows strange behaviour
« Reply #23 on: November 22, 2009, 11:57:46 pm »
Quote
Maybe I've explained it too briefly. I meant after folder checking, where the program asks what you want to do of the new movies found. I usually only import movie informations and deselect the second checkbox (poster). The options remains only during current session. Know is an idiot request, but tried anyway

Oh, OK, I'll do this.
Gentlemen, you can’t fight in here! This is the War Room!

Offline Anson

  • User
  • ***
  • Posts: 46
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #24 on: November 29, 2009, 10:12:34 pm »
Check version number
do you really have the last one?

this seems to be a problem all the time ...
where can people easily see the versions of the program and of plugins,
and where can they easily check for updates ?

--> feature suggestion:
instead of "hiding" the check for updates (for the program itself) in "tools > preferences > internet connection > online updates", it would be nice to have such a check (also) at some more prominent location, eg on the menu option "help". And it also would be nice to have an easily accessible display of version numbers and a check for new versions for all the installed plugins (as already was suggested by other people).
To be in line with several other programs (but that's only my personal preference), these options could go to "help > check" and "help > versions" (or a combined list of loaded and most current version numbers), right above "help > about".

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: IMDB plugin shows strange behaviour
« Reply #25 on: November 29, 2009, 11:44:46 pm »
Plugin versions can be found in "Tools -> Preferences -> Plugins"

There will be an improved update checking functionality available in the next version and I will place a menu item for it under "Help"
Gentlemen, you can’t fight in here! This is the War Room!

Offline Anson

  • User
  • ***
  • Posts: 46
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #26 on: November 30, 2009, 01:55:26 am »
Plugin versions can be found in "Tools -> Preferences -> Plugins"

I had looked everywhere (including this location) for half an hour and didn't find it. After your post i found it in 15 seconds when i took a look at the horizontal scrollbar :-)

since my monitor is HD+ (1920x1200), i now have enlarged the preferences window to avoid any such scrollbars, and PVD even remembers that new size on the next run. VERY nice !

There will be an improved update checking functionality available in the next version and I will place a menu item for it under "Help"

TY 1k times :-)

Offline Overlord

  • Member
  • *
  • Posts: 12
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #27 on: November 30, 2009, 02:47:04 pm »
Nostra is da man.

 8)

Offline KJPVDB

  • Member
  • *
  • Posts: 14
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #28 on: November 30, 2009, 08:51:39 pm »
Hi everybody,

I am sure I'm using the 0.9.2.2 imdb.dll plugin but I still have some of the problems people refer to concerning the tagline field.

1. i see <p> above and below the tag line with movies imported somewhere between november 11th 19:06h and november 16th 13:59h
2. than I imported a movie at november 17th at 18:57h which looks entirely fine
3. and in the 7 movies after that (between november 18th 20:04h and today november 30th 19:55h) the tagline has been replaced by a user comment. (no <p>'s anymore

Another little problem I encountered was importing the movie Adaptation (with Nicolas Cage): it just won't 'take', it seems... ???

Anyway, love the Personal Videodb, appreciate all the effort!

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #29 on: November 30, 2009, 09:57:49 pm »
Quote
I am sure I'm using the 0.9.2.2 imdb.dll plugin

It works for me, so I have to ask—is that the version reported in Preferences - Plugins?

Quote
it just won't 'take', it seems...

What do you mean? If you haven't already, try adding the record and the URL (http://imdb.com/title/tt0268126/), then updating it.

Offline KJPVDB

  • Member
  • *
  • Posts: 14
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #30 on: November 30, 2009, 10:21:55 pm »
Quote
It works for me, so I have to ask
I understand  ;)
Quote
—is that the version reported in Preferences - Plugins?
Yes (and to be extra sure, I checked again after you asked, because I am running the dutch language version).

When I wanted to replace the imdb.dll-plugin tonight, I exited the program, downloaded the plugin and unpacked it in de Plugins directory, replacing the one dated november 15th with this one, dated november 20th. And it says 0.9.2.2 at Preferences - Plugins now.

Quote
try adding the record and the URL (http://imdb.com/title/tt0268126/), then updating it
Ah, I didn't know that trick. That works fine, thanks Rick!

strangely enough: no problem with the movie tagline of 'Adaptation'

An example of comment instead of tagline: Land of the Lost; instead of "Tagline: Right place. Wrong time."  it says:
"I have to agree with Kraig. I too never comment on movies because I
don't believe I'm qualified to give a good review. But this goes down
as the worst movie I think I've ever seen. It was so bad that I had to
see it to the end to see if there was some twist or someone was having
a laugh but there was nothing, zip, zero! Special effects were great
and hence it was clear that a lot of money had been spent on this film.
I love Will Farrel and so I was deeply disappointed when I saw this
film. The story came from a kindergarten class and the plot was
pathetic. I'm curious to know who enjoyed this movie and why because
it's tantamount to torture. If I was any of the actors I'd trike this
from my CV. Really...."

(Actually I disagree with that, I loved this movie. But then again, I love everything with Will Ferrell in it  ;D)

Looking it up on IMDB I see it's a comment of july 14th (Land of the losers); the 'newest' comment.
« Last Edit: November 30, 2009, 10:42:06 pm by KJPVDB »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #31 on: December 01, 2009, 02:04:50 am »
Quote
An example of comment instead of tagline: Land of the Lost...

Works for me. ???

Quote
I love everything with Will Ferrell in it.

Can't help you there either. ;)

Offline KJPVDB

  • Member
  • *
  • Posts: 14
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #32 on: December 01, 2009, 07:43:41 am »
Quote
Land of the Lost
+
Quote
Works for me. Huh
+
Quote
Can't help you there
+
Quote
;)
Well no problem, thanks for listening anyway. I'll look for clues and let you know when I think I found something.

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: IMDB plugin shows strange behaviour
« Reply #33 on: December 01, 2009, 09:10:25 pm »
-Start PVD with -debug command line parameter
-reproduce the problem
-post here the contents of Help -> Log window
Gentlemen, you can’t fight in here! This is the War Room!

Offline Knighted

  • Member
  • *
  • Posts: 13
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #34 on: December 03, 2009, 02:07:48 am »
re: KJPVDB
I had something similar happen to me before I updated my plug-in.  When using the old plug-in I'd get the user comments in the tagline field.  I updated the plug-in and tried to retrieve the proper info from imdb, but the field still wouldn't update.  I then cleared the field of information, and tried to retrieve the information again, and this time it worked fine.

Offline raldo

  • Power User
  • ****
  • Posts: 140
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #35 on: December 03, 2009, 11:31:50 am »
I then cleared the field of information, and tried to retrieve the information again, and this time it worked fine.

I have seen this too. It happens even if the plugin is set to overwrite the field.

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: IMDB plugin shows strange behaviour
« Reply #36 on: December 03, 2009, 02:01:09 pm »
So could you please provide the log file?
Gentlemen, you can’t fight in here! This is the War Room!

Offline Knighted

  • Member
  • *
  • Posts: 13
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #37 on: December 03, 2009, 10:41:10 pm »
I installed the older version of the imdb plugin in an attempt to reproduce the problem.  I could only half-reproduce it.  I was only able to get my hands on v0.9.1.2 of the imdb plugin in.  i think it was 0.9.2.1 that had the user comments in the tagline field. 

However, with the 0.9.1.2 there's still an error in the tagline field: <div class="info-content">", a line break, and then the tagline. 

I updated to 0.9.2.2 and tried to update the field with the correct information, and here's the log from it.  At 4:20pm I cleared the info from the field manually, and imported the movie information from imdb once again, where it worked properly.

I could understand why it wouldn't update properly in this case, since the information in the field is actually correct, only having the <div class="info-content"> and a line break appended to the beginning of it.  However the same thing was happening when the user comments, something completely different, were in the field.

Code: [Select]
(03/12/2009 4:18:23 PM) PVD Version: 0.9.9.14
(03/12/2009 4:18:23 PM) OS: Windows Vista (Build 7600)
(03/12/2009 4:18:23 PM) Plugin loaded: amazon.dll 0.4.3.6
(03/12/2009 4:18:23 PM) Plugin loaded: amazonde.dll 0.1.1.6
(03/12/2009 4:18:23 PM) Plugin loaded: amazonuk.dll 0.1.0.3
(03/12/2009 4:18:23 PM) Plugin loaded: amc.dll 0.3.1.0
(03/12/2009 4:18:23 PM) Plugin loaded: animenfo.dll 0.1.0.2
(03/12/2009 4:18:23 PM) Plugin loaded: csvimp.dll 0.1.3.0
(03/12/2009 4:18:23 PM) Plugin loaded: faffes.dll 0.2.4.3
(03/12/2009 4:18:23 PM) Plugin loaded: filmup.dll 0.1.1.2
(03/12/2009 4:18:23 PM) Plugin loaded: filmup_people.dll 0.1.1.3
(03/12/2009 4:18:23 PM) Plugin loaded: filmup_poster.dll 0.1.1.2
(03/12/2009 4:18:23 PM) Plugin loaded: imdb.dll 0.9.2.2
(03/12/2009 4:18:23 PM) Plugin loaded: imdb_people.dll 0.2.2.3
(03/12/2009 4:18:23 PM) Plugin loaded: impawards.dll 0.1.4.1
(03/12/2009 4:18:23 PM) Plugin loaded: moviemeter.dll 0.1.3.6
(03/12/2009 4:18:23 PM) Plugin loaded: msexcel.dll 0.4.0.0
(03/12/2009 4:18:23 PM) Plugin loaded: ofdb.dll 0.4.1.0
(03/12/2009 4:18:23 PM) Plugin loaded: ofdb_people.dll 0.1.1.4
(03/12/2009 4:18:23 PM) Plugin loaded: plainexp.dll 0.6.1.0
(03/12/2009 4:18:23 PM) Plugin loaded: pvdtotray.dll 0.1.0.1
(03/12/2009 4:18:23 PM) Plugin loaded: scriptint.dll 0.2.4.0
(03/12/2009 4:18:23 PM) Plugin loaded: tvdb.dll 0.1.0.1
(03/12/2009 4:18:23 PM) Plugin loaded: twittpvd.dll 0.1.0.0
(03/12/2009 4:18:23 PM) Plugin loaded: valueconvert.dll 0.1.0.2
(03/12/2009 4:18:23 PM) Compiling script: adultdvdempire.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: adultdvdempire.psf
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: allmovie.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: allmovie.psf
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: animator.ru.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: animator.ru.psf
[Hint] (313:3): Variable 'DIGITS' never used
[Hint] (446:3): Variable 'SELECTEDURL' never used
[Hint] (447:3): Variable 'POS2' never used
[Hint] (447:3): Variable 'I' never used
[Warning] (551:16): "True and" is not needed
[Warning] (582:15): Calculation always evaluates to True
[Warning] (615:15): Calculation always evaluates to True
[Hint] (545:3): Variable 'FILMTYPE' never used
[Hint] (545:3): Variable 'ACTORS' never used
[Hint] (545:3): Variable 'CREATORS' never used
[Hint] (547:3): Variable 'POS2' never used
[Hint] (547:3): Variable 'LEN' never used
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: anime.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: anime.psf
[Hint] (189:2): Variable 'CURPOS' never used
[Hint] (189:2): Variable 'ENDPOS' never used
[Hint] (190:2): Variable 'NAME' never used
[Hint] (190:2): Variable 'URL' never used
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: beyazperde.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: beyazperde.psf
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: kino-teatr.ru.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: kino-teatr.ru.psf
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: Kinomania.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: Kinomania.psf
[Warning] (0:0): "and True" is not needed
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: kinopoisk.psf
(03/12/2009 4:18:23 PM) Script compiled successfully: kinopoisk.psf
(03/12/2009 4:18:23 PM) Executing script binary
(03/12/2009 4:18:23 PM) Compiling script: kinopoisk_cover.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: kinopoisk_cover.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: kinopoisk_person.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: kinopoisk_person.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: kinopoisk_poster.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: kinopoisk_poster.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: kinopoisk_screenshot.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: kinopoisk_screenshot.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: txtinfo_en.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: txtinfo_en.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: txtinfo_ru.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: txtinfo_ru.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: worldart.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: worldart.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: worldart_person.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: worldart_person.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Compiling script: zelluloid.psf
(03/12/2009 4:18:24 PM) Script compiled successfully: zelluloid.psf
(03/12/2009 4:18:24 PM) Executing script binary
(03/12/2009 4:18:24 PM) Script loaded: adultdvdempire.psf 0.1.0.5
(03/12/2009 4:18:24 PM) Script loaded: allmovie.psf 0.1.0.5
(03/12/2009 4:18:24 PM) Script loaded: animator.ru.psf 0.1.0.0
(03/12/2009 4:18:24 PM) Script loaded: anime.psf 0.1.0.0
(03/12/2009 4:18:24 PM) Script loaded: beyazperde.psf 0.1.0.0
(03/12/2009 4:18:24 PM) Script loaded: kino-teatr.ru.psf 0.0.1.0
(03/12/2009 4:18:24 PM) Script loaded: Kinomania.psf 0.1.0.9
(03/12/2009 4:18:24 PM) Script loaded: kinopoisk.psf 1.0.7.13
(03/12/2009 4:18:24 PM) Script loaded: kinopoisk_cover.psf 0.2.1.5
(03/12/2009 4:18:24 PM) Script loaded: kinopoisk_person.psf 0.1.0.9
(03/12/2009 4:18:24 PM) Script loaded: kinopoisk_poster.psf 0.2.1.5
(03/12/2009 4:18:24 PM) Script loaded: kinopoisk_screenshot.psf 0.2.1.5
(03/12/2009 4:18:24 PM) Script loaded: txtinfo_en.psf 0.1.0.0
(03/12/2009 4:18:24 PM) Script loaded: txtinfo_ru.psf 0.1.0.0
(03/12/2009 4:18:24 PM) Script loaded: worldart.psf 0.1.5.0
(03/12/2009 4:18:24 PM) Script loaded: worldart_person.psf 0.1.3.2
(03/12/2009 4:18:24 PM) Script loaded: zelluloid.psf 0.1.0.3
(03/12/2009 4:18:24 PM) Loading database: C:\Users\Mark\Documents\Personal Video Database\movies.pvd
(03/12/2009 4:18:25 PM) GET: http://www.videodb.info/verinfo.txt
(03/12/2009 4:18:42 PM) Logging in...
(03/12/2009 4:18:42 PM) POST: http://www.imdb.com/register-imdb/login?
(03/12/2009 4:18:43 PM) Redirected to: https://secure.imdb.com/register-imdb/login
(03/12/2009 4:18:43 PM) Searching movie information for: Cloudy With A Chance of Meatballs
(03/12/2009 4:18:43 PM) GET: http://www.imdb.com/title/tt0844471/
(03/12/2009 4:19:06 PM) GET: http://www.imdb.com/title/tt0844471/fullcredits#cast
(03/12/2009 4:19:07 PM) GET: http://www.imdb.com/title/tt0844471/business
(03/12/2009 4:19:11 PM) GET: http://www.imdb.com/title/tt0844471/technical
(03/12/2009 4:20:35 PM) Logging in...
(03/12/2009 4:20:35 PM) POST: http://www.imdb.com/register-imdb/login?
(03/12/2009 4:20:35 PM) Redirected to: https://secure.imdb.com/register-imdb/login
(03/12/2009 4:20:35 PM) Searching movie information for: Cloudy With A Chance of Meatballs
(03/12/2009 4:20:35 PM) GET: http://www.imdb.com/title/tt0844471/
(03/12/2009 4:20:36 PM) GET: http://www.imdb.com/title/tt0844471/fullcredits#cast
(03/12/2009 4:20:38 PM) GET: http://www.imdb.com/title/tt0844471/business
(03/12/2009 4:20:39 PM) GET: http://www.imdb.com/title/tt0844471/technical

Offline KJPVDB

  • Member
  • *
  • Posts: 14
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #38 on: December 05, 2009, 01:07:20 pm »
Hi, I tried to reproduce the tagline=usercomment-problem (with the -debug command line parameter 'on'). But I couldn't reproduce it: I started by deleting (really erased, with ctlr+delete) one of the 'problem-movies' and after that PVD imported the tagline just fine. I think the solution is to Ctrl+delete all the movies (or if you know how, just the problem field) and than reloading the data. So it was kind of a caching thing.

Offline clandher

  • Member
  • *
  • Posts: 8
    • View Profile
Re: IMDB plugin shows strange behaviour
« Reply #39 on: December 15, 2009, 09:06:18 am »
Hi
I have a problem. I have 0.9.9.14 version, and the imdb doesn't import the alternative title. I put the last version of imdb plugin, but is the same, it fixed only the rating movies.

It is OK now, i solved the problem.
Thanks for the program
« Last Edit: December 15, 2009, 09:17:11 am by clandher »