Author Topic: [SOLVED] Actors' roles aren't being imported  (Read 20026 times)

0 Members and 1 Guest are viewing this topic.

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
[SOLVED] Actors' roles aren't being imported
« on: August 23, 2010, 04:58:42 pm »
For the past few weeks, when I add a new movie, the IMDB plugin is importing all the usual information except for actors' roles.  I've noticed this happen two or three times before, and it's always corrected itself within a few days.  But like I said, this time it's been going on for quite a while.  I've checked every setting I can think of and can't find any problems.  So, does anyone else know what might be causing this?  Thanks!
« Last Edit: September 23, 2010, 01:14:20 am by rick.ca »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #1 on: August 23, 2010, 07:38:43 pm »
Welcome, RazorHall.

AFAIK, it's not possible to download actors without roles—because that's the form of the data at the source (e.g., "Humphrey Bogart ... Rick Blaine"). There's an option for displaying the role, however: Show credits as role at Preferences - Movies - Information card. Obviously you have this set, or you wouldn't be seeing an roles at all. But it does suggest the problem may be with your configuration file.

When this happens, is the problem confined to the movie you've just downloaded, or are other/all movies affected? Is it a refresh issue—do the roles appear if you collapse and expand the field, change movies, restart the program? Is Show credits as role still set? When it "corrects itself within a few days," do you mean the roles spontaneously appear, or they appear if you download the information again?

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #2 on: August 23, 2010, 09:22:12 pm »
Hi, Rick!

The "show credits as role" box is indeed checked.  And yes, just recently added movies are affected... the actors' names only are displayed in the Actors field, jumbled together with 3 or 4 names per line.  Movies I added weeks/months ago show both the actors and their roles.

Collapsing/expanding the field, restarting the program, etc. has no effect.  The information remains the same for each movie, and the "show credits as role" box remains checked.

When the issue was suddenly corrected in the past, I'd usually notice after adding a new movie.  The roles would just mysteriously be displayed again.  Then, I'd have to go back and re-import the Actors field for the few recent movies that were missing the roles, and all was well.   :)
« Last Edit: August 23, 2010, 10:04:46 pm by RazorHall »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #3 on: August 23, 2010, 11:48:54 pm »
Can you show us an example of the data in the actors field? I don't mean how it looks, but the data itself. To do that, put the record in edit mode, select all and copy the field, and then paste the results here inside "code" tags (use the "#" button).

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: Actors' roles aren't being imported
« Reply #4 on: August 24, 2010, 12:32:10 am »
And you could also provide your IMDB plugin settings by the way ;)
Gentlemen, you can’t fight in here! This is the War Room!

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #5 on: August 24, 2010, 03:37:59 am »
Okay, for example, here is what's in the Actors field of Tropic Thunder:

Code: [Select]
Jeff Kahn, Robert Downey Jr., Anthony Ruivivar, Jack Black, Jay Baruchel, Brandon T. Jackson, Ben Stiller, Eric Winzenried, Steve Coogan, Valerie Azlynn, Matt Levin, David Pressman, Amy Stiller, Danny McBride, Dempsey Silva, Bill Hader, Nick Nolte, Jeff Weidemann, Nadine Ellis, Rachel Avery, Darryl Farmer, Rod Tate, Maria Menounos, Tyra Banks, Christine Taylor, Jel Galiza, Andrea de Oliveira, Josiah Ancheta, Matthew McConaughey, Yvette Nicole Brown, Reggie Lee, Trieu Tran, Brandon Soo Hoo, J. Thomas Chon, Jacob Chon, Tom Cruise, Mini Anden, Mike Hoagland, Jon Voight, Jennifer Love Hewitt, Jason Bateman, Lance Bass, Alicia Silverstone, Don Abernathy, Linda Bella, Denise Bradley, Ella Christopher-Pantoliano, Natalie Cohen, Angela Daun, Clark DeVol, Kaylee Dodson, Jasmine Dustin, Eric Feliciano, Austin Honaker, Miko Hughes, Dave Johnson, Jillian Johnston, Tobey Maguire, Fadhia Carmelle Marcelin, Kaye Marie, Anya Monzikova, The Mooney Suzuki, Chad Mountain, Kevin Pollak, Samantha Sadoff, Becca Sweitzer, Julie Van, Jobeth Wagner
As for my IMDB plugin settings...

Where you choose fields to be imported, all of them are shaded green.  I've also checked the box "Do not add people from awards...".

Under "Configure", I have the following checked: Use Aka search, Download full credits, Download Movie Connections, Download "Also known as", Download Awards, Download "Episodes", and Download box office data.
« Last Edit: August 24, 2010, 03:45:52 am by RazorHall »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #6 on: August 24, 2010, 04:37:45 am »
Quote
Where you choose fields to be imported, all of them are shaded green.

I don't know what bearing this has on your problem, but "shaded green" means "add data if field is empty." What you want is a solid tick mark—meaning "add, overwriting any existing data." These check boxes can be confusing because there appearance varies according to the operating system used. Cycle through the three choices (overwrite - add if empty - do nothing) until you're satisfied you understand what each means. To add to the confusion, the None button changes all fields to "add if empty" rather than the expected (by me, at least)  empty box meaning "do nothing."

Does this change your interpretation of what you're seeing? I don't see how it explains you not getting the roles in the first place.

Quote
Under "Configure", I have the following checked: Use Aka search

I don't know why it should matter, but do you notice any difference if this option is turned off?

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #7 on: August 24, 2010, 05:01:41 am »
Yes, those check boxes were a bit confusing at first, but shortly after joining the forum, I found a helpful post that explained how they worked.   :)   I've experimented with both the shades and checkmarks, but lately I can't get the roles to download either way.  It's baffling!

Unfortunately, leaving the "Use Aka search" check box empty has no effect either.  


Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #8 on: August 24, 2010, 10:34:14 pm »
Okay, for example, here is what's in the Actors field of Tropic Thunder...

Oops. That was a meaningless test. What appears in Edit mode is also changed by the option to display roles.  :-[

I still think it unlikely the plugin is somehow not downloading the roles, and this must somehow be a display issue. The roles option not being recognized properly would explain the behaviour—if it were the same for all movies. So I'm baffled. Nevertheless, it would be worthwhile to test for an issue with the configuration file...

Start the program with the -portable switch. You can do this with the provided batch file, or create a shortcut with the switch. This will cause the program to ignore your configuration file, and create a new default one in the installation directory. Test to see if there are any differences in the problem behaviour.

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #9 on: August 25, 2010, 01:12:55 am »
I used the batch file you mentioned to open the program, then added a new movie.  Only the actors' names were displayed, so I went into Preferences and checked the "show credits as role" box.  That made no difference, so I added another movie just to be sure, and got the same result.  I went ahead and tried again all the other suggestions that have been mentioned earlier in this thread, and still no luck.
« Last Edit: August 25, 2010, 01:18:22 am by RazorHall »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #10 on: August 25, 2010, 03:12:52 am »
The next straw to grasp at would be to test a new database...

1. Delete the pvdconfig.ini file that should be in your installation folder as a result of the last test.
2. Rename (so you can reinstate it later if you like) the imdbconf.cfg file in the \Plugins folder.
3. If your database is in the default folder, move it elsewhere—so the program won't find it. This is important—I don't think this test will mean anything your existing database is opened.
4. Start the program, again with the -portable switch. It should automatically create a new default database.
5. Check that the default setting of the plugin are sufficient for testing (e.g., Actors is checked in Overwrite fields). Otherwise, just use the defaults.
6. Add some movies and see if the same problem exists.

BTW, what OS are you using?

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #11 on: August 25, 2010, 06:14:25 pm »
Well, I followed the steps, added a few new movies, and it still imports everything except the roles.  The OS I'm using is Windows XP.

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #12 on: August 25, 2010, 09:59:49 pm »
I'm stumped. Hopefully we've at least created some meaningful information for nostra to consider.

Maybe some other XP users can tell us whether or not they're having similar problems. I note that Import from IMDB Not Working also involves an issue that started with the last update of the IMDb plugin—running on XP.

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: Actors' roles aren't being imported
« Reply #13 on: August 25, 2010, 11:35:04 pm »
To be honest, I have no idea what is happening there as well :(
Maybe some screenshots (movie record before, after) and the log (start PVD with -debug command line parameter and then select Help -> Log from the main menu after reproducing the problem) would provide some clues.
Gentlemen, you can’t fight in here! This is the War Room!

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #14 on: August 26, 2010, 01:09:03 am »
I've attached a couple of screenshots... one movie added before the problem started and one after.  Let me know if that's not what you were looking for.

Here's the log after adding a movie for testing purposes.

Code: [Select]
?»?(8/25/2010 6:48:02 PM) PVD Version: 0.9.9.21
(8/25/2010 6:48:02 PM) OS: Windows XP Workstation
(8/25/2010 6:48:02 PM) Plugin loaded: amazon.dll 0.4.3.6
(8/25/2010 6:48:02 PM) Plugin loaded: amazonde.dll 0.1.1.6
(8/25/2010 6:48:02 PM) Plugin loaded: amazonfr.dll 0.1.0.3
(8/25/2010 6:48:02 PM) Plugin loaded: amazonuk.dll 0.1.0.3
(8/25/2010 6:48:02 PM) Plugin loaded: amc.dll 0.3.1.0
(8/25/2010 6:48:02 PM) Plugin loaded: animenfo.dll 0.1.0.2
(8/25/2010 6:48:02 PM) Plugin loaded: csvimp.dll 0.1.3.1
(8/25/2010 6:48:02 PM) Plugin loaded: faffes.dll 0.2.5.1
(8/25/2010 6:48:02 PM) Plugin loaded: filmup.dll 0.1.1.3
(8/25/2010 6:48:02 PM) Plugin loaded: filmup_people.dll 0.1.1.4
(8/25/2010 6:48:02 PM) Plugin loaded: filmup_poster.dll 0.1.1.2
(8/25/2010 6:48:02 PM) Plugin loaded: imdb.dll 0.9.3.8
(8/25/2010 6:48:02 PM) Plugin loaded: imdb_people.dll 0.2.2.6
(8/25/2010 6:48:02 PM) Plugin loaded: impawards.dll 0.1.4.1
(8/25/2010 6:48:02 PM) Plugin loaded: moviemeter.dll 0.1.3.7
(8/25/2010 6:48:02 PM) Plugin loaded: msexcel.dll 0.4.1.0
(8/25/2010 6:48:02 PM) Plugin loaded: ofdb.dll 0.4.1.0
(8/25/2010 6:48:02 PM) Plugin loaded: ofdb_people.dll 0.1.1.4
(8/25/2010 6:48:02 PM) Plugin loaded: plainexp.dll 0.7.1.1
(8/25/2010 6:48:02 PM) Plugin loaded: pvdtotray.dll 0.1.0.1
(8/25/2010 6:48:02 PM) Plugin loaded: scriptint.dll 0.2.6.0
(8/25/2010 6:48:02 PM) Plugin loaded: tmdb.dll 0.1.0.1
(8/25/2010 6:48:02 PM) Plugin loaded: tvdb.dll 0.1.1.0
(8/25/2010 6:48:02 PM) Plugin loaded: twittpvd.dll 0.1.0.0
(8/25/2010 6:48:02 PM) Plugin loaded: valueconvert.dll 0.1.0.2
(8/25/2010 6:48:02 PM) Compiling script: adultdvdempire.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: adultdvdempire.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: allmovie.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: allmovie.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: animator.ru.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: animator.ru.psf
[Hint] (313:3): Variable 'DIGITS' never used
[Hint] (446:3): Variable 'SELECTEDURL' never used
[Hint] (447:3): Variable 'POS2' never used
[Hint] (447:3): Variable 'I' never used
[Warning] (551:16): "True and" is not needed
[Warning] (582:15): Calculation always evaluates to True
[Warning] (615:15): Calculation always evaluates to True
[Hint] (545:3): Variable 'FILMTYPE' never used
[Hint] (545:3): Variable 'ACTORS' never used
[Hint] (545:3): Variable 'CREATORS' never used
[Hint] (547:3): Variable 'POS2' never used
[Hint] (547:3): Variable 'LEN' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: beyazperde.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: beyazperde.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: covers.mrcat.org_cover.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: covers.mrcat.org_cover.psf
[Hint] (295:3): Variable 'TYPECARRIERINFILMDESC' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: covers.mrcat.org_disk.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: covers.mrcat.org_disk.psf
[Hint] (295:3): Variable 'TYPECARRIERINFILMDESC' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kino-teatr.ru.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kino-teatr.ru.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kinopoisk.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kinopoisk.psf
[Hint] (3205:3): Variable 'I' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kinopoisk_cover.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kinopoisk_cover.psf
[Hint] (744:3): Variable 'IND' never used
[Hint] (744:3): Variable 'STEP' never used
[Hint] (744:3): Variable 'NSHOWPOSTERS' never used
[Hint] (748:3): Variable 'SIZE' never used
[Hint] (750:3): Variable 'SEARCHRESULT' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kinopoisk_person.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kinopoisk_person.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kinopoisk_poster.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kinopoisk_poster.psf
[Hint] (744:3): Variable 'IND' never used
[Hint] (744:3): Variable 'STEP' never used
[Hint] (744:3): Variable 'NSHOWPOSTERS' never used
[Hint] (748:3): Variable 'SIZE' never used
[Hint] (750:3): Variable 'SEARCHRESULT' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: kinopoisk_screenshot.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: kinopoisk_screenshot.psf
[Hint] (744:3): Variable 'IND' never used
[Hint] (744:3): Variable 'STEP' never used
[Hint] (744:3): Variable 'NSHOWPOSTERS' never used
[Hint] (748:3): Variable 'SIZE' never used
[Hint] (750:3): Variable 'SEARCHRESULT' never used
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: mymovies.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: mymovies.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: txtinfo_en.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: txtinfo_en.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: txtinfo_ru.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: txtinfo_ru.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: worldart.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: worldart.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: worldart_person.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: worldart_person.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Compiling script: zelluloid.psf
(8/25/2010 6:48:02 PM) Script compiled successfully: zelluloid.psf
(8/25/2010 6:48:02 PM) Executing script binary
(8/25/2010 6:48:02 PM) Script loaded: adultdvdempire.psf 0.1.0.6
(8/25/2010 6:48:02 PM) Script loaded: allmovie.psf 0.1.0.5
(8/25/2010 6:48:02 PM) Script loaded: animator.ru.psf 0.1.0.0
(8/25/2010 6:48:02 PM) Script loaded: beyazperde.psf 0.1.0.0
(8/25/2010 6:48:02 PM) Script loaded: covers.mrcat.org_cover.psf 0.0.0.2
(8/25/2010 6:48:02 PM) Script loaded: covers.mrcat.org_disk.psf 0.0.0.2
(8/25/2010 6:48:02 PM) Script loaded: kino-teatr.ru.psf 0.0.1.0
(8/25/2010 6:48:02 PM) Script loaded: kinopoisk.psf 1.0.7.28
(8/25/2010 6:48:02 PM) Script loaded: kinopoisk_cover.psf 0.2.1.11
(8/25/2010 6:48:02 PM) Script loaded: kinopoisk_person.psf 0.1.0.16
(8/25/2010 6:48:02 PM) Script loaded: kinopoisk_poster.psf 0.2.1.11
(8/25/2010 6:48:02 PM) Script loaded: kinopoisk_screenshot.psf 0.2.1.11
(8/25/2010 6:48:02 PM) Script loaded: mymovies.psf 0.1.0.6
(8/25/2010 6:48:02 PM) Script loaded: txtinfo_en.psf 0.1.0.1
(8/25/2010 6:48:02 PM) Script loaded: txtinfo_ru.psf 0.1.0.1
(8/25/2010 6:48:02 PM) Script loaded: worldart.psf 0.1.5.0
(8/25/2010 6:48:02 PM) Script loaded: worldart_person.psf 0.1.5.0
(8/25/2010 6:48:02 PM) Script loaded: zelluloid.psf 0.1.0.5
(8/25/2010 6:48:03 PM) Loading database: C:\Documents and Settings\XXXXXXXXXXXX\My Documents\Personal Video Database\MYCOLLECTION.PVD
(8/25/2010 6:48:04 PM) UpdateToolbar: 1
(8/25/2010 6:48:04 PM) UpdateToolbar: 2
(8/25/2010 6:48:06 PM) UpdateToolbar: 3
(8/25/2010 6:48:06 PM) UpdateToolbar: 4
(8/25/2010 6:48:24 PM) Logging in...
(8/25/2010 6:48:24 PM) POST: http://www.imdb.com/register-imdb/login?login=XXXXXXXXXX&password=XXXXXXXX
(8/25/2010 6:48:25 PM) Redirected to: https://secure.imdb.com/register-imdb/login
(8/25/2010 6:48:25 PM) Searching movie information for: Wizard of Oz, The
(8/25/2010 6:48:25 PM) GET: http://imdb.com/title/tt0032138/
(8/25/2010 6:48:26 PM) Redirected to: http://www.imdb.com/rg/parked-domains/imdb.com/title/tt0032138/
(8/25/2010 6:48:26 PM) Redirected to: http://www.imdb.com/title/tt0032138/
(8/25/2010 6:48:27 PM) GET: http://imdb.com/title/tt0032138/keywords
(8/25/2010 6:48:28 PM) Redirected to: http://www.imdb.com/rg/parked-domains/imdb.com/title/tt0032138/keywords
(8/25/2010 6:48:28 PM) Redirected to: http://www.imdb.com/title/tt0032138/keywords
(8/25/2010 6:48:29 PM) GET: http://www.imdb.com/title/tt0032138/fullcredits#cast
(8/25/2010 6:48:34 PM) GET: http://imdb.com/title/tt0032138/movieconnections
(8/25/2010 6:48:34 PM) Redirected to: http://www.imdb.com/rg/parked-domains/imdb.com/title/tt0032138/movieconnections
(8/25/2010 6:48:35 PM) Redirected to: http://www.imdb.com/title/tt0032138/movieconnections
(8/25/2010 6:48:38 PM) GET: http://imdb.com/title/tt0032138/releaseinfo#akas
(8/25/2010 6:48:38 PM) Redirected to: http://www.imdb.com/rg/parked-domains/imdb.com/title/tt0032138/releaseinfo
(8/25/2010 6:48:39 PM) Redirected to: http://www.imdb.com/title/tt0032138/releaseinfo
(8/25/2010 6:48:39 PM) GET: http://imdb.com/title/tt0032138/awards
(8/25/2010 6:48:40 PM) Redirected to: http://www.imdb.com/rg/parked-domains/imdb.com/title/tt0032138/awards
(8/25/2010 6:48:41 PM) Redirected to: http://www.imdb.com/title/tt0032138/awards
(8/25/2010 6:48:42 PM) GET: http://www.imdb.com/title/tt0032138/business
(8/25/2010 6:51:13 PM) Searching posters for: Wizard of Oz, The
(8/25/2010 6:51:13 PM) GET: http://www.amazon.com/exec/obidos/search-handle-url/index=dvd&field-keywords=The+Wizard+of+Oz
(8/25/2010 6:51:18 PM) GET: http://ecx.images-amazon.com/images/I/51zyJrjPvlL._SL160_AA115_.jpg
(8/25/2010 6:51:19 PM) GET: http://ecx.images-amazon.com/images/I/51wCtfJjbLL._SL160_AA115_.jpg
(8/25/2010 6:51:21 PM) GET: http://ecx.images-amazon.com/images/I/51hpclDODLL._SL160_AA115_.jpg
(8/25/2010 6:51:22 PM) GET: http://ecx.images-amazon.com/images/I/511rtFjpmkL._SL160_AA115_.jpg
(8/25/2010 6:51:23 PM) GET: http://ecx.images-amazon.com/images/I/51KqfMmhQnL._SL160_AA115_.jpg
(8/25/2010 6:51:24 PM) GET: http://ecx.images-amazon.com/images/I/51Q8D2D58HL._SL160_AA115_.jpg
(8/25/2010 6:51:25 PM) GET: http://ecx.images-amazon.com/images/I/51A0gAq80JL._SL160_AA115_.jpg
(8/25/2010 6:51:26 PM) GET: http://ecx.images-amazon.com/images/I/51VGYEW849L._SL160_AA115_.jpg
(8/25/2010 6:51:27 PM) GET: http://ecx.images-amazon.com/images/I/516cb11%2BUpL._SL160_AA115_.jpg
(8/25/2010 6:51:28 PM) GET: http://ecx.images-amazon.com/images/I/51kyiFOn-ZL._SL160_AA115_.jpg
(8/25/2010 6:51:29 PM) GET: http://ecx.images-amazon.com/images/I/51xYNiMIjyL._SL160_AA115_.jpg
(8/25/2010 6:51:29 PM) GET: http://ecx.images-amazon.com/images/I/6182X8ZGDCL._SL160_AA115_.jpg

[attachment deleted by admin]
« Last Edit: August 26, 2010, 01:16:57 am by RazorHall »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #15 on: August 26, 2010, 01:33:39 am »
Quote
I have no idea what is happening there as well

Which do you think is more likely...

1. the plugin is failing to get the roles,
2. they're not being saved in the database, or
3. the program is not displaying them?

RazorHall, you could run a Plain Text Export using the following template to determine whether or not the role data actually exists in the database.

Code: [Select]
%OPTIONS%
encoding="ANSI"
filter="Text Files|*.txt"
%OPTIONS%
{%value=title}:
{%value=actors template="pages\actors.ptm" params="full"}

And to test the display behaviour of the field, try editing Actors, changing [actor1, actor2, etc.] to [actor1 ... role1, actor2 ... role2, etc.]. Normal behaviour depends on whether the "show roles" option is set. If it is, the added roles will appear, and I suppose this would imply they weren't recorded in the database by the plugin. If the option is not set (or the program is not recognizing that it is), the added roles will not be displayed. Note that even if this doesn't appear to "work," the field will still be saved exactly as edited.

I just saw your last post. Try removing the login from your plugin configuration. It's not necessary, and might be the cause of the problem—although I doubt it. Whether logged in or not, I suppose when you visit http://www.imdb.com/title/tt0032138/fullcredits#cast using your browser, the credit data (including roles) is displayed normally.

BTW, you should find the program loads a little faster if you delete the plugins and scripts you're not using.

Offline RazorHall

  • User
  • ***
  • Posts: 52
    • View Profile
Re: Actors' roles aren't being imported
« Reply #16 on: August 26, 2010, 02:03:17 am »
The Plain Text Export showed no role data for recently added movies.

The roles I enter myself are displayed correctly after editing the Actors field.

Removing my login information from the IMDB plugin had no effect.

Thanks for the tip about plugins/scripts!  And I appreciate your efforts in trying to figure out why I'm having this issue.   :)

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #17 on: August 26, 2010, 03:03:30 am »
So it would seem might be a problem with the plugin running on XP. Maybe some other XP users can confirm.

buah

  • Guest
Re: Actors' roles aren't being imported
« Reply #18 on: August 26, 2010, 06:43:43 am »
This user can't reproduce the issue on his WinXP. Everything works perfect.

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: Actors' roles aren't being imported
« Reply #19 on: August 26, 2010, 06:56:59 am »
Thanks, buah. I figured it couldn't be that obvious, but we're running out of straws to grasp at. :P