Author Topic: Folder access weirdness  (Read 1867 times)

0 Members and 1 Guest are viewing this topic.

Offline AimHere

  • Older Power User
  • *****
  • Posts: 209
    • View Profile
Folder access weirdness
« on: October 13, 2013, 07:55:51 pm »
Hi,

I've noticed a bit of weirdness with regard to how PVD looks for its database files on my hard disk.

When I set up Windows 7 on this PC, I relocated the "My Documents" folder off of my C: drive to the E: drive. (To do this in Windows, you open Windows Explorer, find and right-click on "My Documents", click "Location" tab, then "Move...") The folder I moved it to is "E:\Aimhere's Documents", though this still appears in Windows Explorer as "E:\My Documents".

Now, this arrangement works for most programs. All of my other apps which attempt to store files in "My Documents" get redirected to the correct folder on E:. But for some reason PVD doesn't work correctly with this.

If I try to create a new database in PVD, in the "Save as..." dialog I can navigate to the folder path "Computer > E: > My Documents > PVD Files" and see my existing database files. So I type in a new file name (let's call it "TEST") and click "Save". But if I flip over to Windows Explorer, I find the database file has been saved as "E:\Aimheres Documents\PVD Files\TEST.pvd" instead of "E:\Aimhere's Documents\PVD Files\TEST.pvd" (note the difference... PVD saved it in a folder named without an apostrophe.)

What's more, the new 1.x version of PVD won't even open database files from "E:\Aimhere's Documents\PVD Files" (if I navigate to this folder in the "Open..." dialog and choose a file, no data is displayed in the app window)... unless the file is ALSO present in "E:\Aimheres Documents\PVD Files". If the file is not present in the latter folder, PVD 1.x just creates a new, empty database there with the given filename. (The 0.9.x version will at least open a file from its original location in "E:\Aimhere's Documents\PVD Files".)

It looks like PVD's internal routines for managing folder paths are somehow stripping the apostrophe from "E:\Aimhere's Documents" prior to opening the files, resulting in the creation of "E:\Aimheres Documents" (if it doesn't already exist) and writing database files in subfolders of that. And 1.x appears to expect to load databases from that location as well.

If this issue can't be fixed, I may need to move my databases to a different folder (perhaps just "E:\PVD files") and forget about using the "My Documents" folder. I wouldn't mind doing this, but PVD's code really ought to be fixed so it works as expected with folder names containing apostrophes.

Aimhere

(P.S. - this folder-name issue explains why I was having trouble loading my existing movie database from 0.9.x into 1.x, per my post in the "Apostophe Catastrophe" thread. Once I moved the copy of my database to the folder without the apostrophe, 1.x was able to load it. It seems PVD just doesn't deal correctly with apostrophes, in folder names as well as in database fields!)
« Last Edit: October 13, 2013, 08:11:10 pm by AimHere »

Offline nostra

  • Administrator
  • *****
  • Posts: 2852
    • View Profile
    • Personal Video Database
Re: Folder access weirdness
« Reply #1 on: October 13, 2013, 11:05:47 pm »
I could reproduce and fix the issue.
Gentlemen, you can’t fight in here! This is the War Room!

Offline AimHere

  • Older Power User
  • *****
  • Posts: 209
    • View Profile
Re: Folder access weirdness
« Reply #2 on: October 14, 2013, 11:39:09 pm »
Thanks.

 

anything