Author Topic: Allmovie.com https  (Read 15035 times)

0 Members and 1 Guest are viewing this topic.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #20 on: December 28, 2019, 09:26:50 am »
AllMovie.com_new_HTTPS script
version 1.1.2.9


Okay, here's what the log file said about the Allmovie script:

(12/27/2019 5:40:41 PM) Compiling script: AllMovie.com HTTPS.psf
(12/27/2019 5:40:41 PM) Could not compile script: AllMovie.com HTTPS.psf
[Error] (402:75): Unknown identifier 'AllMovie'

Thanks for the reported error. My mistake, I overlooked it. I fixed it and AllMovie.com HTTPS.psf is working fine.

New version of AllMovie.com_new_HTTPS script  is attached.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline RazorHall

  • User
  • ***
  • Posts: 62
    • View Profile
Re: Allmovie.com https
« Reply #21 on: December 28, 2019, 06:25:43 pm »
Allmovie now appears as an import option, but I get the following error when I run it:

Socket Error #11001
Host not found.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #22 on: December 28, 2019, 07:01:01 pm »
Allmovie now appears as an import option, but I get the following error when I run it:

Socket Error #11001
Host not found.

I need a log file and a movie title or a more detailed description of when and how this error occurs. Repeat the procedure as described in this link below. Then I'll see and know what's going on.

http://www.videodb.info/forum_en/index.php/topic,4109.msg21008.html#msg21008
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline RazorHall

  • User
  • ***
  • Posts: 62
    • View Profile
Re: Allmovie.com https
« Reply #23 on: December 28, 2019, 07:43:31 pm »
I've attached the log file.  I receive that error every time I run the Allmovie script.  I tried it on a few different titles and got the same result each time.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #24 on: December 28, 2019, 09:39:10 pm »
I've attached the log file.  I receive that error every time I run the Allmovie script.  I tried it on a few different titles and got the same result each time.

I can't figure out what's wrong because the script works fine for me. Try AllMovie.com_new_HTTPS script version 1.1.2.7, which you can find at this link below, to see if this version also reports the same error.

http://www.videodb.info/forum_en/index.php/topic,4109.msg20986.html#msg20986
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline RazorHall

  • User
  • ***
  • Posts: 62
    • View Profile
Re: Allmovie.com https
« Reply #25 on: December 28, 2019, 10:09:37 pm »
No change when using the other version of the file.   :(

I don't know if this helps at all, but if I try running the script with only a title, and no link in the URL field, I get this error:

IOHandler value is not valid.
« Last Edit: December 28, 2019, 10:19:35 pm by RazorHall »

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #26 on: December 29, 2019, 08:31:21 am »
No change when using the other version of the file.   :(

I don't know if this helps at all, but if I try running the script with only a title, and no link in the URL field, I get this error:

IOHandler value is not valid.

This error occurs. because AllMovie uses an https link and PVD does not recognize the https link, only recognizes the http link. It is necessary to activate the Proxy server in the PVD settings under Internet Connections, where the following information is entered in the appendix below.
Quote
It will also act PVD, you must also PVD settings \ Internet connection, find the "Proxy" and confirm. In the "Server" field enter "localhost" Port settings to 80 . Only with this configuration will function properly PVD. PVD is used only proxy port 80.

For this to work, you also need a Proxomitron program. If you are not already using it, then you will find more at this link in the appendix below.
Tests Proxomitron. I think this would be an ideal solution for your problems. I also attach a default.cfg file that already has an added solution for the Allmovie.com https connection. How and what is described in topic:
Proxomitron - next https solution for PVD.

The Proxomitron program I use on my own can be found more at this link below.
http://www.videodb.info/forum_en/index.php/topic,4125.msg20409.html#msg20409

I also attach the latest default.cfg file that already has an added solution for the Allmovie.com https connection.


default.cfg is attached.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #27 on: December 29, 2019, 08:43:15 am »
The Proxomitron program I use on my own can be found more at this link below.
http://www.videodb.info/forum_en/index.php/topic,4125.msg20409.html#msg20409.

Notice:
All 4 parts of the Proxomitron1 (and rar format) file need to be downloaded if you want to have all the files and Proxomitron will work properly.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #28 on: December 29, 2019, 04:29:39 pm »
AllMovie.com_new_HTTPS script
version 1.1.3.0

Some beauty fixes and improvements to the scripts code.

New version of AllMovie.com_new_HTTPS script  is attached.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline RazorHall

  • User
  • ***
  • Posts: 62
    • View Profile
Re: Allmovie.com https
« Reply #29 on: December 29, 2019, 06:44:37 pm »
Changing the proxy settings and using Proxomitron has allowed the Allmovie script to work in most cases.  Thanks, Ivek!

I've only gotten one error so far, on one title, and that's Zombie Dearest (https://www.allmovie.com/movie/zombie-dearest-v570551).  The error is:

HTTP/1.1 400 Host Not Found

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #30 on: December 29, 2019, 08:14:41 pm »
Changing the proxy settings and using Proxomitron has allowed the Allmovie script to work in most cases.  Thanks, Ivek!

Welcome. I'm glad the script is working and we have resolved the problem with the proxy settings.

I've only gotten one error so far, on one title, and that's Zombie Dearest (https://www.allmovie.com/movie/zombie-dearest-v570551).  The error is:

HTTP/1.1 400 Host Not Found

Thanks for the error. The culprit is the poster download code, which I also assumed was because I myself had a reported error when I tested the script. The error will probably be fixed tomorrow.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline RazorHall

  • User
  • ***
  • Posts: 62
    • View Profile
Re: Allmovie.com https
« Reply #31 on: December 29, 2019, 11:41:48 pm »
Thanks for the error. The culprit is the poster download code, which I also assumed was because I myself had a reported error when I tested the script. The error will probably be fixed tomorrow.

That's awesome.  Thank you again for all your assistance and hard work! 

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #32 on: December 30, 2019, 06:31:49 pm »
AllMovie.com_new_HTTPS script
version 1.1.3.1

Poster error corrected. It was repaired some more mistakes. However, a link to the Wayback Machine Archive has been added, where you can find an archived version of the AllMovie movie page if it has been archived.


Quote
AllMovie data:         PVD field:      FN:      Type/Comments:
--------------         ---------      --      -------------
.
.
.
AMG "movie_id" ID      ~AMG Wayback Machine Archive~    memo (link to Search on Wayback Archive)

.
.
.
// ~AMG "movie_id" ID~
 endPos:=curPos;
 endPos:=PosFrom('var gptAdSlots = [];',HTML,curPos);
 curPos:=PosFrom('googletag.pubads().setTargeting('+#39+'movie_id'+#39+', '+#39+'v',HTML,endPos)+Length('googletag.pubads().setTargeting('+#39+'movie_id'+#39+', '+#39+'v');
   endPos:=PosFrom(#39+');',HTML,curPos);
   TmpStr2:=Copy(HTML,curPos,endPos-curPos);
    //TmpStr2:=RemoveTags(Trim(Copy(HTML,curPos,endPos-curPos)),false);
 AddCustomFieldValueByName('AMG Wayback Machine Archive','<link url="http://web.archive.org/web/*/http://www.allmovie.com/work/'+TmpStr2+'">AllMovie Wayback Machine Archive</link>');
 if TmpStr2 <> '' then LogMessage('      Parse Results AMG ID1:'+TmpStr2);

New version of AllMovie.com_new_HTTPS script  is attached.
« Last Edit: December 30, 2019, 06:39:17 pm by Ivek23 »
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline afrocuban

  • Older Power User
  • *****
  • Posts: 362
    • View Profile
Re: Allmovie.com https
« Reply #33 on: January 09, 2020, 12:35:13 am »
Thank you and Happy New Year, dear Ivek!

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #34 on: January 26, 2021, 10:52:02 am »
Here is the AllMovie.com HTTPS_Test script which has a new url entry in the normal Url field as well as when searching for results, which may be the basis for
Pvd MOD version of the program for the future. It also has some fixes and new pieces of code. If users like the script, all these code updates will be added in the new version, otherwise without the new version of entering the url in the normal Url field as well as when searching for results.

AllMovie.com HTTPS_Test script is attached.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline afrocuban

  • Older Power User
  • *****
  • Posts: 362
    • View Profile
Re: Allmovie.com https
« Reply #35 on: January 26, 2021, 03:56:02 pm »
Thanks Ivek.

For example, instead http://www.allmovie.com/movie/fruitvale-station-v575941 I now got http://www.allmovie.com/movie/v575941

so it works flawlessly and please include it to a new version!


May I kindly ask you to teach me how to remove year from Title1 custom field? You can post piece of code here, and I will paste it in my sample of AllMovie script. I need it badly, because how it is now I'm getting year twice: once from Title1 and once from regular "Year" field so in the skin, year is visible twice.




« Last Edit: January 26, 2021, 04:00:56 pm by afrocuban »

Offline afrocuban

  • Older Power User
  • *****
  • Posts: 362
    • View Profile
Re: Allmovie.com https
« Reply #36 on: January 26, 2021, 04:15:54 pm »
I think I got it.

Instead of
AddCustomFieldValueByName('Title1',TmpStr2);

I put

AddCustomFieldValueByName('Title1',TmpStr1);

Am i right?

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2511
    • View Profile
Re: Allmovie.com https
« Reply #37 on: January 26, 2021, 08:46:41 pm »
I think I got it.

Instead of
AddCustomFieldValueByName('Title1',TmpStr2);

I put

AddCustomFieldValueByName('Title1',TmpStr1);

Am i right?

Yes, you are right. If that doesn't work, add this piece of code

Quote
      TmpStr2:=Copy(HTML,curPos,endPos-curPos);
        debug_pos1:=Pos('(',TmpStr2);   
   if debug_pos1 >0 then TmpStr2:=Copy(TmpStr2,0,debug_pos1-1);

   AddCustomFieldValueByName('Title1',TmpStr2);
   LogMessage('      Parse Results Title2: '+TmpStr2);
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline afrocuban

  • Older Power User
  • *****
  • Posts: 362
    • View Profile
Re: Allmovie.com https
« Reply #38 on: January 27, 2021, 12:37:49 am »
Thanks Ivek. It looks like it works, but I'll keep on my mind piece of code as a backup.

Best regards

Offline afrocuban

  • Older Power User
  • *****
  • Posts: 362
    • View Profile
Re: Allmovie.com https
« Reply #39 on: January 27, 2021, 01:20:05 am »
Thanks Ivek.

For example, instead http://www.allmovie.com/movie/fruitvale-station-v575941 I now got http://www.allmovie.com/movie/v575941

.. but both url''s will be kept in the URL field. Is there a way to automatically clean all "old" url's? Also, now I think of a scenario I had. I had mass import of episodes from AllMovie.com, for example "Modern Family". For some episodes that has common titles, like "Halloween" I wasn't offered to pick the title, but the script automatically imported movie "Halloween" by John Carpenter (https://www.allmovie.com/movie/halloween-v21317) and not the episode of the same title - (https://www.allmovie.com/movie/modern-family--halloween-v544859).

But, I wasn't worried, because after each season mass import, I went to manually check URL field of each episode, and if url didn't contain "modern family" in allmovie url (please compare 2 url's above), I knew it was wrong url, so I went to site and manually found proper url for the episode.

This will definitely not be possible with new url's, and I don't see any benefits of using new url's and also we would have to most likely manually clean "old" url's which for me is impossible for 7k movies.

So, I would definitely like to keep old url's and sorry for I wasn't thinking thoroughly in my previous post about this.