Author Topic: All Plugins stopped working !  (Read 1901 times)

0 Members and 1 Guest are viewing this topic.

Offline gear

  • User
  • ***
  • Posts: 114
    • View Profile
All Plugins stopped working !
« on: April 17, 2018, 06:07:05 pm »
"Import Movie Information using IMDB (EN) pluging" button was the last to work but, today it also stopped working with the message "IO Handler..."etc. making the PVD unusable, except for manual copy/paste from IMDB, which is impossible.

Can anybody confirm that the Proxomitron solution works ?

Gear

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #1 on: April 17, 2018, 08:09:18 pm »
"Import Movie Information using IMDB (EN) pluging" button was the last to work but, today it also stopped working with the message "IO Handler..."etc. making the PVD unusable, except for manual copy/paste from IMDB, which is impossible.

Can anybody confirm that the Proxomitron solution works ?

Gear

It was the same with me today, as you have already described. Even a few days ago, I had problems with this, for the first time the problems started after March 20 (I found a notice in the Russian section of the forum). Already then I had to arrange it default.cfg (1.0.2.7 Update topic for see to the more information), which I myself had to use repeatedly. Today, downloading information from IMDb web pages without this does not work.  Now I can also confirm that IMDb plugins and scripts work with the Proxomitron solution.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline gear

  • User
  • ***
  • Posts: 114
    • View Profile
Re: All Plugins stopped working !
« Reply #2 on: April 18, 2018, 04:12:41 pm »
Hello Ivek,

Have installed Proximitron (ProxN45j.exe) on my Windows 10 and your default.cfg as per your instructions, overwriting the original one but still nothing works in PVD with Proximitron running.

What am I doing wrong?

Gear

20 April 2018 Update: Followed step by step your instructions, removed the extra files not mentioned in your instructions and finally Proxomitron works with the PVD plugins!
« Last Edit: April 20, 2018, 05:58:33 pm by gear »

Offline afrocuban

  • Power User
  • ****
  • Posts: 187
    • View Profile
Re: All Plugins stopped working !
« Reply #3 on: April 19, 2018, 12:44:04 am »
Same here. Stopped today.

Offline afrocuban

  • Power User
  • ****
  • Posts: 187
    • View Profile
Re: All Plugins stopped working !
« Reply #4 on: April 21, 2018, 09:37:28 pm »


20 April 2018 Update: Followed step by step your instructions, removed the extra files not mentioned in your instructions and finally Proxomitron works with the PVD plugins!

Gear,

It would be great if you'd share with the rest of us which files that weren't mentioned in Ivek's instructions you deleted, thus made PVD imports from IMDb. I did everything I could imagine, but still no luck. Thanks in advance.


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #5 on: April 22, 2018, 06:07:20 am »
20 April 2018 Update: Followed step by step your instructions, removed the extra files not mentioned in your instructions and finally Proxomitron works with the PVD plugins!

It would be fine if you would describe and share this, how and what you did, along with other users. I will then add those experiences to Proxomitron topic so that others can also read these experiences.

Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Borea

  • Member
  • *
  • Posts: 16
    • View Profile
Re: All Plugins stopped working !
« Reply #6 on: April 22, 2018, 08:55:21 am »
Same here.

Also, the work around method of "pasting the IMDB url into PVD" does not work any more.

Receiving "IOHandler value is not valid".

What a pity.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #7 on: April 22, 2018, 12:27:04 pm »
Attached I will Proxomitron1 (in rar format) file, which I use and everything works okay.

We needed that because I could even add it to the forum.

First part
Attached Proxomitron1.part1.rar. zip file
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #8 on: April 22, 2018, 12:29:34 pm »
Second part
Attached Proxomitron1.part2.rar. zip file.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #9 on: April 22, 2018, 12:31:18 pm »
Third part
Attached Proxomitron1.part3.rar. zip file.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #10 on: April 22, 2018, 12:33:17 pm »
Fourth part
Attached Proxomitron1.part4.rar. zip file.

Notice:

First, unzip, then unpack the Proxomitron1 rar file as many times as needed to make the final look the way it is on the attached image.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #11 on: April 23, 2018, 07:48:21 am »
Tell me if it's working now.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline setget

  • Member
  • *
  • Posts: 3
    • View Profile
Re: All Plugins stopped working !
« Reply #12 on: April 23, 2018, 10:15:08 am »
It works fine (for me): default.cfg!

Offline Borea

  • Member
  • *
  • Posts: 16
    • View Profile
Re: All Plugins stopped working !
« Reply #13 on: April 23, 2018, 05:36:28 pm »
Hi Ivek,

Thank you for your reply. I appreciate your efforts to keep PVD up and running.

Proxomitron did not work for me. I must have done something wrong.

I unzipped Proxomitron as you suggested and also checked (studied) "Topic: 1.0.2.7" Update page.

1.) Run the Proxomitron program
2.) Run the PVD program
3.) Start any Amazon plugin and then allow or not allow the operation of Amazon plugin

"Under number 3, in this case, run any Imdb plugin or script and then allow or not allow the operation of Imdb plugin or script."


*
This is what I have done...

1- Run Proxomitron with the new "default cfg"
2- Run PVD
3- Open a blank form using the "+" (new) icon
4- Put the title of the new movie into the "title" or "alternative title" field
5- From the "Import" box select "AMAZON (EN)" plugin (!)
6- Run Import function

Is that what I am supposed to do?

When and how am I supposed to run "IMDB (EN)" plugin?

 

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #14 on: April 24, 2018, 07:00:16 am »
This is what I have done...

1- Run Proxomitron with the new "default cfg"
2- Run PVD
3- Open a blank form using the "+" (new) icon
4- Put the title of the new movie into the "title" or "alternative title" field
5- From the "Import" box select "AMAZON (EN)" plugin (!)
6- Run Import function

Is that what I am supposed to do?

When and how am I supposed to run "IMDB (EN)" plugin?

You can, but under number 5, select "IMDB (EN)" plugin instead of "AMAZON (EN)" plugin.

Use IMDB (EN)" plugin when you want to download IMDB information for a particular movie.

Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Borea

  • Member
  • *
  • Posts: 16
    • View Profile
Re: All Plugins stopped working !
« Reply #15 on: April 24, 2018, 05:48:55 pm »
I am getting "IOHandler value is not valid" error.

Thanks for your efforts anyway.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #16 on: April 24, 2018, 06:24:39 pm »
I am getting "IOHandler value is not valid" error.

Thanks for your efforts anyway.

I'm guessing that this error occurs because you do not have a running Proxomitron program or you do not have these proxy server settings.

Quote
It will also act PVD, you must also PVD settings \ Internet connection, find the "Proxy" and confirm. In the "Server" field enter "localhost" Port settings to 80 . Only with this configuration will function properly PVD. PVD is used only proxy port 80.
(See image)
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Borea

  • Member
  • *
  • Posts: 16
    • View Profile
Re: All Plugins stopped working !
« Reply #17 on: April 24, 2018, 07:02:53 pm »
Ivek,

Thanks once more. I fixed the proxy setting. Now it works, but...

I get garbled "Title" and "Original Title" data. Something like: "var ue_t0=ue_t0||+new Date();"

I get proper data for the: "Also Known As", "Year", "Genre", "Director", "Actors", "Release Date", "Date Added" fields.

I do not get data for the: "Category", "Country", "Original Language", "IMDB Rating", "Description", "Comments", "Awards", "Duration" fields.

This is still acceptable for me, because it is better then opening a blank form and copy/paste all the fields from the relevant IMDB page (!).

(I do not need all the fields.)

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #18 on: April 24, 2018, 08:09:08 pm »
Ivek,

Thanks once more. I fixed the proxy setting. Now it works, but...

Thank you. It's nice to hear that the thing is working now. As far as "but" is concerned, it is also a cure for it. I will answer, but I apologize in advance if the answer is delaying some day, because at the same time I am fixing and testing several Imdb scripts at once. That is why I can not do everything faster, as well as other important things that are important for everyday life (it is also due to the fact that it has been about 5 months since then when I no longer have a father, because at that time unfortunately he died). I will try to help you solve these problems as soon as possible.
« Last Edit: April 25, 2018, 07:41:52 am by Ivek23 »
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21


Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2098
    • View Profile
Re: All Plugins stopped working !
« Reply #19 on: April 25, 2018, 07:41:32 pm »
I get garbled "Title" and "Original Title" data. Something like: "var ue_t0=ue_t0||+new Date();"

In IMDB Title Problems topic you will find the Imdb Movie Info (title) script, which removes these problems. There you will also find the IMDB title.batch file in 7z form. There are also detailed instructions on what to designate for the script and what for the Imdb plugin.

Unzip the IMDB title.batch file and copy it to the Plugins program folder, where there is also the Imdb.dll file.

I do not get data for the: "Category", "Country", "Original Language", "IMDB Rating", "Description", "Comments", "Awards", "Duration" fields.

In IMDB MOVIE and PEOPLE topic you will find Imdb Top 250, IMDb Rating and Studio (2) script, which solves these problems.

What information is downloaded into the normal fields and in the custom fields, see the pictures. Script settings are on pictures that are stored in the sshot 7z file.
Ivek23
Win 7 32bit, 64bit   PVD v0.9.9.21