Author Topic: Episodes TV Series Problem  (Read 12917 times)

0 Members and 1 Guest are viewing this topic.

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2435
    • View Profile
Re: Episodes TV Series Problem
« Reply #40 on: October 02, 2021, 10:04:24 am »
Great job Ivek!
I've been trying the new scripts and they all seem to work fine.

I still have trouble with season trees in series:
When I run the new IMDB Movie(episodelist) (a) script and IMDB Movie(episodelist) script using proxomitron I get the error message HTTP/1.1 404 Not Found.
What seems to be the problem?

The same mistake happened to me today. However, the cause was an internet connection lost and the test IMDb script could not connect to the server at www.imdb.com

Maybe this is just one of the causes of your problems.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD


Offline afrocuban

  • Older Power User
  • *****
  • Posts: 347
    • View Profile
Re: Episodes TV Series Problem
« Reply #41 on: October 06, 2021, 07:02:43 pm »
Maybe this piece of code from series script explains a bit more?

Quote
   if (Pos('404 Not Found',Result)>0) then begin  //Banned IP. WEB_SPECIFIC.
        If BYPASS_SILENT Then ShowMessage('The URL is not in use (404 Not Found).'+Chr(13)+'Go to the provider web in order to in order to'+Chr(13)+'find the good page',SCRIPT_NAME);
        LogMessage(Chr(9)+Chr(9)+'      404 Not Found|');
        Result:=''; //Fatal error
    End;
   if (Pos('404 Error - IMDb',Result)>0) then begin  //Banned IP. WEB_SPECIFIC.
        If BYPASS_SILENT Then ShowMessage('The URL is not in use (404 Error - IMDb).'+Chr(13)+'Go to the provider web in order to in order to'+Chr(13)+'find the good page',SCRIPT_NAME);
        LogMessage(Chr(9)+Chr(9)+'      404 Error - IMDb|');
        Result:=''; //Fatal error

Offline Ivek23

  • Global Moderator
  • *****
  • Posts: 2435
    • View Profile
Re: Episodes TV Series Problem
« Reply #42 on: October 07, 2021, 09:12:13 am »
Maybe this piece of code from series script explains a bit more?

Quote
   if (Pos('404 Not Found',Result)>0) then begin  //Banned IP. WEB_SPECIFIC.
        If BYPASS_SILENT Then ShowMessage('The URL is not in use (404 Not Found).'+Chr(13)+'Go to the provider web in order to in order to'+Chr(13)+'find the good page',SCRIPT_NAME);
        LogMessage(Chr(9)+Chr(9)+'      404 Not Found|');
        Result:=''; //Fatal error
    End;
   if (Pos('404 Error - IMDb',Result)>0) then begin  //Banned IP. WEB_SPECIFIC.
        If BYPASS_SILENT Then ShowMessage('The URL is not in use (404 Error - IMDb).'+Chr(13)+'Go to the provider web in order to in order to'+Chr(13)+'find the good page',SCRIPT_NAME);
        LogMessage(Chr(9)+Chr(9)+'      404 Error - IMDb|');
        Result:=''; //Fatal error

Thanks, afrocuban for this warning.

still have trouble with season trees in series:
When I run the new IMDB Movie(episodelist) (a) script and IMDB Movie(episodelist) script using proxomitron I get the error message HTTP/1.1 404 Not Found.
What seems to be the problem?
This happpens with all series when I try to run IMDB Movie(episodelist) (a) script and IMDB Movie(episodelist) script.
I can run IMDB_[EN][HTTPS]-a script, but the Imdb Movie Info-2a script gives the same error message.

All of the above scripts have the following piece of code in the ParsePage function
Quote
function ParsePage(HTML:String;URL:AnsiString):Cardinal; //BlockOpen
Begin
LogMessage('Function ParsePage BEGIN ====================== |');
LogMessage('Global Var-Mode | '+IntToStr(Mode)+' |');

Wait (pauseBeforeLoad);
HTML:=HTMLToText(HTML);
HTML:=StringReplace(HTML,'http://imdb.com','http://www.imdb.com',True,True,False);
LogMessage('     Parsing search Movie search results');

If (0<Pos('404 Not Found',HTML)) OR (0<Pos('HTTP/1.1 404 Not Found',HTML)) Then Begin
    ShowMessage('No results.','IMDb Search Results');
    Result:=prError;
    Exit;
   LogMessage('   -------- ParsePage Error Result ( '+IntToStr(Result)+' )');
   LogMessage('Function ParsePage smSearch-prError END======================|');
   LogMessage('Function ParsePage prError END======================|');
End;


If Pos('Find - IMDb',HTML) > 0 Then Begin
.
.
.
, which is probably the cause of these problems.

Block this part of the code for each of the above scripts.
Quote
//If (0<Pos('404 Not Found',HTML)) OR (0<Pos('HTTP/1.1 404 Not Found',HTML)) Then Begin
//    ShowMessage('No results.','IMDb Search Results');
//    Result:=prError;
//    Exit;
//   LogMessage('   -------- ParsePage Error Result ( '+IntToStr(Result)+' )');
   //LogMessage('Function ParsePage smSearch-prError END======================|');
   //LogMessage('Function ParsePage prError END======================|');
//End;

Then do a retest for each script separately to see if the same error still occurs.
Ivek23
Win 10 64bit (32bit)   PVD v0.9.9.21, PVD v1.0.2.7, PVD v1.0.2.7 + MOD