Author Topic: $1,000,000 importing issue question  (Read 3247 times)

0 Members and 1 Guest are viewing this topic.

Offline zatarra.dantes

  • User
  • ***
  • Posts: 42
    • View Profile
$1,000,000 importing issue question
« on: June 05, 2009, 11:32:55 pm »
hi everyone,

this is a $1,000,000 question...

1. i create the database from scratch with all the information updated
2. i export all the information to a customized xml file and one of the many fields is <release>{%value=rdate}</release>
3. i open the xml with excel and i modify/add values (dates) in the missing cells in the "release" column
4. i save the file as .xls
5. i import the .xls file into a new database created from scratch as well
6. it shows the release dates and everything is fine exactly as the first database without any problem
7. i export AGAIN all the information to the SAME customized xml file (so that i can have all the missing release dates added)

and GUESS WHAT?

the only data missing is the release dates... can you believe that???

now, i go and create another xml file very simple just title/year/release date and i export from the second database, the one that contains all the updated release dates and GUESS WHAT? it does not work either...

what is killing me is the fact that i can see the release dates on every single movie info on the second database, but i cannot export it again using the same xml export template.

there is anything i am missing in the whole picture?

thanks
dom

Offline zatarra.dantes

  • User
  • ***
  • Posts: 42
    • View Profile
Re: $1,000,000 importing issue question
« Reply #1 on: June 06, 2009, 12:09:44 am »
ok a little update...


i updated about 30 movies out of the almost 2300 stored on the database.

after updating i tested the xml export using the same customized template as above and i was able to see the release date... but only of those originally stored on the first database, in other words the one downloaded from IMDB.

so i continue ignoring the ones that i added although it shows them on the pvd interface...

this is getting weird...

stay tune up... we might solve the issue...ahah

Offline zatarra.dantes

  • User
  • ***
  • Posts: 42
    • View Profile
Re: $1,000,000 importing issue question
« Reply #2 on: June 06, 2009, 12:30:13 am »
ok now i know what is the problem...

you cannot add the releasing date manually... i first thought it was a problem with excel and xml but then i manually added the date in one of the movies... i can still see the releasing date on pvd interface but it will ignore it during export...

that is a way to fix this?
btw i also deleted all the config.ini and any movies.pvd so i re-re-started with a brand new database...

please help me... :(

i want to review this last test: you CAN modify the date manually but before you import the data from an excel file otherwise it will kind of lock the export feature.
« Last Edit: June 06, 2009, 12:40:25 am by zatarra.dantes »

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: $1,000,000 importing issue question
« Reply #3 on: June 06, 2009, 12:52:54 am »
YES! And I'm in dire need of $1,000,000...

I sense you might not aware be there are two standard fields: rdate (Release date) and release (currently not used by any plugins AFAIK). So from your description, it seems you're exporting rdate and re-importing as release. Remember, you won't see release unless there is a value in it, or you're in edit mode.

Quote
you cannot add the releasing date manually...

I'm not sure what you mean by this. You should be able to edit or import to either of these fields, like any other. Last modified can't be changed—it's a system value.

Offline zatarra.dantes

  • User
  • ***
  • Posts: 42
    • View Profile
Re: $1,000,000 importing issue question
« Reply #4 on: June 06, 2009, 01:09:58 am »
yes... i just found out there are two release dates... in fact i came here to update my status... but you were faster...

thank you anyway, i really appreciate your help and wonderful suport...

i used the wrong release field in the excel import...

i costed me 3hrs of extra work... but now i know better...

about the $1,000,000... i am working on... i saved already $27.94... ahah

thanks rick

Offline rick.ca

  • Global Moderator
  • *****
  • Posts: 3241
  • "I'm willing to shoot you!"
    • View Profile
Re: $1,000,000 importing issue question
« Reply #5 on: June 06, 2009, 01:19:24 am »
You're welcome. It did occur to me someone who actually had $1,000,000 to spare might not offer to part with it quite so easily. ;)

 

anything